Need help with a glitch...

I need help with a glitch, it happens with cameras on the newest Garry’s Mod update and I want it to STOP

Here is my problem:

So… It happens after making a save that has a camera in it. When I load that save, the camera is there, but when ever I press the hot key I use for it, it enters the camera’s view and doesn’t exit it AT ALL… I’ve tried deleting the camera, but it does’t work, I’ve tried removing it through the “user options”, but still hasn’t worked. I have also tried placing down a camera, but it doesn’t replace the other camera. In fact, it doesn’t even seem to be noticed as a camera, yet it notices the other one as one. It’s like as if the camera saved to the save isn’t even noticed by the system yet, it’s noticed by the key controls, and then glitches and then you can’t exit it. No, the game hasn’t crashed on me, I can still enter the Main Menu, I can still use the Model Menu, as well as the Player Menu( or what ever you call the menu that shows up while holding down “C”), but I can’t seem to exit out of the camera’s view.

It seems like the only way I can avoid this glitch is by deleting any cameras that are in the map before saving it. Yet, it’s completely retarded because I’m trying to make a Gmod video (like the ones on YouTube that are made by Kitty0, Rubberfruit, Starmix, Etc.) and it’s really irritating because if I have to stop immediately in the middle of making a scene and exit out of Garry’s Mod, and then when loading the save, I’d have to find the place where the camera was viewing from, or I’d have to remake the scene ALL OVER AGAIN.

If anyone has a solution to fixing this problem, PLEASE tell me so I can get to it IMMEDIATELY.

Thank you for taking your time to read this, I’d appreciate it A LOT if you were to help me with this problem and maybe tell me how it’s or what causes it and how I can fix that.

                                                                                                                                                           **~{WetWerth}~**