Need help with DarkRP server

So i’m trying to make a dedicated server off of my computer in which really isin’t made for server hosting but I think it’ll be fine. But I am having a lot of troubles and would like some help. *Note I am using SteamCMD)

1st problem: Sometimes I spawn in without anything, meaning I don’t spawn in with a physgun or gravgun. And sometimes, I only spawn in with an RPG.

2nd problem: I can’t change it to the gamemode that I want (Darkrp) and i’m even putting it the correct way (Most people say this is correct) in my start.bat. I had it to +gamemode darkrp in front of the maxplayers.

3rd problem: I need a good admin mod. I have used ULX and Evolve and both are great but ULX does cause some problems for my server.

4th problem: Even if I port foward, it doesn’t show up in the “internet” tab. I port fowarded my public IP to 27015 for TCP and 27005 for UDP.

5th problem: I need a bank/inventory swep/mod and can’t find any good, yet simple ones.

6th problem: I also need a car dealer to obviously buy cars. Also, I need one where I can add custom cars because I plan to add motorcycles.

7th problem: How do I make jobs for donators/mods/admins only?

Thank you guys for all the help! ^^

  1. Make sure PlayerLoadout is called and sbox_weapons is set to 1.
  2. Change the darkrp folder to all lowercase as well as your +gamemode call.
  3. Be specific on what problems it causes. You can try Maestro if you want.
  4. You need 27015-27017 TCP and UDP.
  5. Try Ritz bank. I see it on every other server.
  6. http://scriptfodder.com There’s a search feature.
  7. http://wiki.darkrp.com/index.php/DarkRP:CustomJobFields Look at the customcheck option.

Thanks for the speedy reply.

1.I don’t know what you mean by “playerloadout is called” but I haven’t tried sbox_weapons 1. Will try tomorrow though
2. I have already done that and it doesn’t work. It just gives me this:“Error loading gamemode:!isvalidgamemode [darkrp]” and continuosly crashes.
3. Well, I tried switching from Superadmin to Operator once and I got a Lua error and the ULX menu was stuck on my screen and I couldn’t get it off no matter what. I do like ULX though, I just don’t like that error. Also, it seems difficult to add groups.
4. I just tried it and it still doesn’t work. I used an open port checker for it and it says it’s closed.
5. I found the Ritz bank thing but i’m too poor to afford anything right now.
6. Same goes for #5, too poor to afford anything right now.
7. Yeah, I saw it earlier on when I was trying to code my first custom job. Thing is idk how to make it so that it is specifically for Donators, like I don’t know how to create a group for donators/trusted, for ULX. Then idk where to insert “donator” and stuff into the script.

If you’re getting ULX errors then you’re not changing things correctly. Also, make sure you have the latest DarkRP and you setup the directory correctly (it should go garrysmod/gamemodes/darkrp/gamemode, contents, etc.). If the port is still closed, then contact your ISP and ask about port forwarding for your specific router/plan. Lastly, you can always learn to code the addons your want yourself: http://forum.facepunch.com/showthread.php?t=1337945

Thanks for the response.
I’m gonna try ULX again and figure things out. I’m pretty sure I have the latest version of darkrp. I downloaded it from the darkrp wiki. And I’ll also try coding addons today as well if I have any time

I got my DarkRP sitation fixed, it was because I put the darkrp modification folder in the wrong place. Now I have two new problems. In which one is because my port isin’t opened even after I port forwarded. It worked previously. Second problem is I got one of my custom jobs to work but the other 3 that I coded are giving me a Lua error in which one of the brackets are opened, in which they’re not.

Post the error and file in


 tags.