Need Help with Fast DL

I have been trying to get the fast dl to download on my server to download a model and a few sounds for a custom weapon on my server, but I have tried everything I found on the web and nothing has worked.
I have tried making a resources.lua file with


resource.AddFile( "sound\siege\big_explosion.wav" )

and it downloads the sound, but I can’t hear it, as if it’s downloading nothing.
sv_allowdownload and sv_allowupload are both set to 0 because I heard it could interfere with the fast dl, but do these need to be set to 1 to download the models and sounds? I need help. I am new at this and I don’t know what to do.

Hi.

Try changing the \ to /, it may think you’re trying to escape letters into the string. Also, please run the following commands in your console, join the server, and paste the output here in CODE tags.


developer 4
download_debug 1

This fixed the sounds. The sounds now download without any problems, but my materials and models like


resource.AddFile( "addons/for_allah/models/weapons/w_jb.vvd" )
resource.AddFile( "addons/for_allah/materials/vgui/entities/Thumbs.db" )

download every time I join the server and it’s as if they didn’t download in the game. The sounds work but the models and materials don’t. They are still errors.
Do sv_allowdownload and sv_allowupload have to be set to 1 for models and materials to work or would it mess with my fast dl to set them to 1?

it should just be

resource.AddFile( “models/weapons/w_jb.mdl” );

sv_allowdownload can be 0 or 1, it doesn’t really matter. sv_allowupload isn’t related to FastDL at all :).

But the models and materials are not in my garrysmod/matertals and garrysmod/models folders. They are in an addon in my garrysmod/addons folder

That doesn’t matter with resource.AddFile :slight_smile:

When I set them to that nothing downloaded and it still shows the model as an error. The code is now


resource.AddFile( "models/weapons/w_jb.vvd" )
resource.AddFile( "materials/vgui/entities/Thumbs.db" )

Try adding w_jb.mdl, not .vvd. Also, you can’t send Thumbs.db files (it’s really just a file used for the folder viewer on Windows anyway, players don’t need it).

[editline]20th January 2013[/editline]

And do this too please, this will tell us if it’s even adding the files to be downloaded

I have both w_jb.mdl and w_jb.vvf in there. When i looked In console it showed these errors.


clientside lua startup!
[resource.AddFile] File models\weapons\w_jb.vvd didn't exist!
[resource.AddFile] File materials\vgui\entities\Thumbs.db didn't exist!
[resource.AddFile] File models\weapons\w_jb.mdl didn't exist!

etc. etc.

Anyone know how to fix this?