Need help with installing GUIstudio and Studio Compiler

Ok, so I am reinstalling these tools but for some reason I can’t get them to work right

GUIStudio

I chose the bin path for the OB engine but for some reason I can’t set the EP 1 path. It says its missing a “gameconfig” file. The OB bin has it though

Studio Compiler

I get 2 different errors

The OB bin error
http://filesmelt.com/downloader/Studio1.JPG

EP 1 Error
http://filesmelt.com/downloader/Studio_21.JPG

A while backed Bloocobalt gave me a fixed version that worked fine when placed but he isn’t online now

replace your game info with this

“GameInfo”
{
FileSystem
{
SteamAppId 220 // mount hl2 content for vgui platform stuff
ToolsAppId -211 // Tools will load this (ie: source SDK caches) to get things like materials\debug,
SearchPaths
{
vconfig |gameinfo_path|. // for all the vconfig stuff
vconfig platform // for all the vgui stuff
}
}
}

edit: sorry about the copy and paste and btw everytime u run gmod u will have to retype that into the game info

Thanks but I really don’t want to remind myself to retype something all the time

Anyways, I have GUIstudio working thanks to Silver Spirit.

Now I need a fix for Studio compiler

Bump

GUIstudio is now not working, I keep getting


Unable to find gameinfo.txt. Solutions:

1. Read http://www.valve-erc.com/srcsdk/faq.html#NoGameDir
2. Run vconfig to specify which game you're working on.
3. Add -game <path> on the command line where <path> is the directory that gameinfo.txt is in.
Unable to find gameinfo.txt. Solutions:

1. Read http://www.valve-erc.com/srcsdk/faq.html#NoGameDir
2. Run vconfig to specify which game you're working on.
3. Add -game <path> on the command line where <path> is the directory that gameinfo.txt is in.

save it as a notepad and copy paste it change name every time then paste into your folder its what i do :slight_smile:

This isn’t much related, but now (after having to put the FileSystem_Steam.dll back in AGAIN, damn patches), It wont let me compile a model with 32 materials because it has more than 32 materials (according to the compiler @.@) anyone know how to fix it? (i’ve tried all the compilers and they say the same thing ¬.¬).

Edit: I’ve split it into two models instead, but if anyone knows how to fix it let me know :slight_smile:

I can always do that but I want it simple like it used to be