Need some assistance....

Well, As you guys may have known… The newest Gmod update screwed up a lot of the gamemodes…

I am just here to ask if anyone can help me fix my Fallout Mod gamemode, I can’t offer anything except for Admin on the server and Global Moderator on the forums (If you don’t run off with the script, if you do… you’ll regret it).

I CANNOT offer any money (Except maybe monthly payments… possibly), because as it is now, I’m barely able to keep the server up. So if you would like to help out someone who is down on their luck, and help out a great community, then please, please do.

My community has been screwed over by these updates about 6 times now, And i am tired of it…

“Why not do it yourself” You ask? Because i am just starting out with Lua, I still got a lot to learn… and i doubt i could do it myself. Which is why i am asking for you guys help.

If you are interested, or want to discuss more details, then please add me Via steam: http://steamcommunity.com/id/Fletcher


(User was banned for this post ("Undescriptive thread title" - mahalis))

Don’t even bother with monetary anything in this community. The people who really have knowledge of programming here would help you without asking for pay. Only the dolts who know little to nothing will rip you off.

Perhaps you can paste individual errors here, and I can help you out, one by one. :smile:

Well, i never bothered with going onto the server, it’s just that everyone said that it was broken…

Is it possible for you to add me on steam?

Have you actually ran an update of your server after the update? If it is not up to date then nobody will be able to connect to it, and that’s just normal.

Yes i have ran an update, That’s the reason why the gamemode broke. It worked perfectly fine yesterday. (And people have connected to it.)

I’m currently working on a large scale project at the moment, so Steam Friends is out of the question, temporarily.

Oh then i should just PM you with the errors?

Just post them here, then other developers can help you as well.

Okay, Here is the log from when i joined the server. (Also, ULX stopped working aswell?)

Convar r_rootlod has conflicting FCVAR_CHEAT flags (child: FCVAR_CHEAT, parent: no FCVAR_CHEAT, parent wins)
Convar r_eyeglintlodpixels has conflicting FCVAR_CHEAT flags (child: FCVAR_CHEAT, parent: no FCVAR_CHEAT, parent wins)
Convar r_skin has conflicting FCVAR_CHEAT flags (child: no FCVAR_CHEAT, parent: FCVAR_CHEAT, parent wins)
Convar mat_softwareskin has conflicting FCVAR_CHEAT flags (child: no FCVAR_CHEAT, parent: FCVAR_CHEAT, parent wins)
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Didn’t find particle function render_blobs
Didn’t find particle function lennard jones force
Garry’s Mod server.dll Build #072 [Nov 20 2009 20:20:38]
maxplayers set to 1
Unknown command “sv_backspeed”
GetAllManifestFiles: Unable to load maplist.txt


                                                   
__________________________________________________ 
                                                   
Tap DELETE once after select your song to play your wav. Tap it again to stop playing. 
__________________________________________________ 
                                                   
www.hlss.us 
                                                   
--The Best Website For Everything HLSS Related-- 
__________________________________________________ 
--- Missing Vgui material vgui/..\vgui\icon_con_high
--- Missing Vgui material vgui/../vgui/icon_con_high.vmt
Network: IP 192.168.0.175, mode MP, dedicated No, ports 27015 SV / 27005 CL
Connecting to 69.162.64.226:27015...
Connected to 69.162.64.226:27015

fallout
Map: gm_atomic
Players: 1 / 32
Build: 3740
Server Number: 1

No pure server whitelist. sv_pure = 0
env_cubemap used on world geometry without rebuilding map. . ignoring: decals/prodflrlghta
SOLID_VPHYSICS static prop with no vphysics model! (models/props/de_train/handrail_yardb-catwalk.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/de_train/handrail_yardb-catwalk.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/de_train/handrail_yardb-catwalk.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/de_train/handrail_yardb-catwalk.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/de_train/handrail_yardb-catwalk.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/de_train/handrail_yardb-catwalk.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/cs_office/light_outsidewall.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props/de_train/railroadtrackslong.mdl)
KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file scripts/soundscapes_gm_atomic.txt
apoc.vault, (*playrandom*), (*rndwave*), 
Lua initialized (Lua 5.1)
--------------Weather Loaded Clientside--------------
Warning: vgui.Create failed to create the VGUI component (ControlPanel)

Trace: 
	1: Line 32	"Trace"	includes/extensions/debug.lua
	2: Line 26	"(null)"	includes/modules/controlpanel.lua
	3: Line -1	""	(tail call)
	4: Line 7	"CreateNpcPly"	autorun/CombineControlV2.lua
	5: Line 109	"(null)"	autorun/CombineControlV2.lua


includes/modules/controlpanel.lua:27: controlpanel.Get() - Error creating a ControlPanel!
You're calling this function too early! Call it in a hook!

Warning: vgui.Create failed to create the VGUI component (DFrame)
includes/extensions/vgui_sciptedpanels.lua:134: attempt to index local 'panel' (a nil value)
======== Installing Table (De)Serialiser Module | ver: 1.4 ========
LuaGetfile: Not Loading autorun\Billy Mays.lua
Couldn't include file 'autorun/Billy Mays.lua' (File not found)
pills.lua:38: chunk has too many syntax levels
-NPC Control-
Main Content Loaded
Episode 2 Content Loaded!
--------------------
RunConsoleCommand blocked - sent before player spawned (sv_tags)
autorun/crysis_playermodels.lua:2: unfinished string near '"models/players/kano/tactical/'
autorun/cSx_NPC's.lua:10: unfinished string near '"models/players/kano/ninja/'
======== Beam NetVars Lib v0.71 Installed ========
=== Loading Wire Menus ===
ERROR! Module 'zlib_b64' not found!
RunConsoleCommand blocked - sent before player spawned (ZLib_Installed)
==== Advanced Duplicator v.1.72 shared module installed! ====
==== Advanced Duplicator v.1.741 client module installed! ====
=== Loading Wire Model Packs ===
	Loaded: PHXWireModels.txt
	Loaded: Spacebuild Model Pack.txt
	Loaded: default.txt
	Loaded: cheeze_buttons2.txt
	Loaded: wire_model_pack_1.txt
	Loaded: wire_model_pack_1plus.txt
	Adding Cheeze's Buttons Pack
	Jaanus' Thruster Pack
loading materials
loading material: cable/rope_icon
loading material: cable/cable2
loading material: cable/xbeam
loading material: cable/redlaser
loading material: cable/blue_elec
loading material: cable/physbeam
loading material: cable/hydra
loading material: arrowire/arrowire
loading material: arrowire/arrowire2
Registering gamemode 'sandbox' derived from 'base'
-NPC Control-
Main Content Loaded
Episode 2 Content Loaded!
--------------------
-NPC Control-
Main Content Loaded
Episode 2 Content Loaded!
--------------------
-NPC Control-
Main Content Loaded
Episode 2 Content Loaded!
--------------------
Loading Wire Tools
run on client
--- Missing Vgui material HUD/killicons/weapon_rpg
Error! Flag "$vertexcolor" is multiply defined in material "sprites/doom/ammo_rocket"!
Error! Flag "$vertexcolor" is multiply defined in material "sprites/doom/ammo_rocket"!
entities\mario_sent_atomic_bomb\shared.lua:6: unfinished string near '"RayFanMan(RayFan9876)'
Folder	=	entities/mario_sent_atomic_bomb
AdminSpawnable	=	true
Spawnable	=	false
Couldn't register Scripted Entity mario_sent_atomic_bomb - the Type field is empty!
entities\mk-82-fragile_sent_atomic_bomb\shared.lua:6: unfinished string near '"RayFanMan(RayFan9876)'
Folder	=	entities/mk-82-fragile_sent_atomic_bomb
AdminSpawnable	=	true
Spawnable	=	false
Couldn't register Scripted Entity mk-82-fragile_sent_atomic_bomb - the Type field is empty!
--- Missing Vgui material HUD/killicons/weapon_rpg
effects/bodyshot/init.lua:17: ')' expected near 'physics'
Loading achievements...
KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file settings/spawnlist/billy mays.txt
8, Entries, (*1*), 
KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file settings/spawnlist/billy mays.txt
8, (*Entries*), (*1*), 
KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file settings/spawnlist/gordon_models.txt
SpawnMenu, (*Entries*), (*4*), 
KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file settings/spawnlist/hydra.txt
8, Entries, (*1*), 
KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file settings/spawnlist/hydra.txt
8, (*Entries*), (*1*), 
KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file settings/spawnlist/megaman 64.txt
1, (*Entries*), (*1*), 
KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file settings/spawnlist/phazon suit samus.txt
1, (*Entries*), (*1*), 
KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file settings/spawnlist/phoenix-storm's_premium_models_d.txt
20, (*Entries*), (*21*), 
KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file settings/spawnlist/pikmin.txt
21, (*Entries*), (*21*), 
KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file settings/spawnlist/Rickenbacker 4003.txt
27, Entries, (*1*), 
KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file settings/spawnlist/Rickenbacker 4003.txt
27, (*Entries*), (*1*), 
KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file settings/spawnlist/sabermenu.txt
1, (*Entries*), (*16*), 
KeyValues Error: LoadFromBuffer: missing { in file settings/spawnlist/Spiderman.txt
(*0*), (*Entries*), (*1*), 
KeyValues Error: LoadFromBuffer: missing { in file settings/spawnlist/[L4D] Foliage.txt
(*4*), (*Entries*), (*50*), 
KeyValues Error: LoadFromBuffer: missing { in file settings/spawnlist/[L4D] Foliage.txt
(*4*), (*Entries*), (*50*), 
KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file settings/spawnlist/[phx]super flat bars.txt
SpawnMenu, (*Entries*), 
KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file settings/spawnlist/[phx]super flat plates.txt
SpawnMenu, (*Entries*), 
KeyValues Error: RecursiveLoadFromBuffer:  got EOF instead of keyname in file settings/spawnlist/[phx]super flat tris.txt
SpawnMenu, (*Entries*), 
SWEP (weapon_ep2sniper) is derived from non existant SWEP (ep2snip_base) - Expect errors!ERROR: Trying to derive entity airlock from non existant entity base_rd_entity!
ERROR: Trying to derive entity base_default_res_module from non existant entity base_rd_entity!
ERROR: Trying to derive entity sent_rg_bullet from non existant entity base_point!
ERROR: Trying to derive entity sent_nuke_radiation from non existant entity base_point!
ERROR: Trying to derive entity base_livable_module from non existant entity base_rd_entity!
ERROR: Trying to derive entity base_weapons_module from non existant entity base_rd_entity!
ERROR: Trying to derive entity railgun from non existant entity base_rd_entity!
Sending 1066 'User Info' ConVars to server (cl_spewuserinfoconvars to see)
Bad sequence (2047 out of 5 max) in GetSequenceLinearMotion() for model 'Player.mdl'!
Bad sequence (2047 out of 5 max) in GetSequenceLinearMotion() for model 'Player.mdl'!
Bad sequence (2047 out of 5 max) in GetSequenceLinearMotion() for model 'Player.mdl'!
Bad sequence (2047 out of 5 max) in GetSequenceLinearMotion() for model 'Player.mdl'!
Bad sequence (2047 out of 5 max) in GetSequenceLinearMotion() for model 'Player.mdl'!
Bad sequence (2047 out of 5 max) in GetSequenceLinearMotion() for model 'Player.mdl'!
Bad sequence (2047 out of 5 max) in GetSequenceLinearMotion() for model 'Player.mdl'!
Bad sequence (2047 out of 5 max) in GetSequenceLinearMotion() for model 'Player.mdl'!
Bad sequence (2047 out of 5 max) in GetSequenceLinearMotion() for model 'Player.mdl'!
Redownloading all lightmaps
Finished! 55 achievements loaded!
This server is running ULib version 2.30.
[ULIB] Loading SHARED module: ulx_init.lua
Unknown command: ulx
Unknown command: ulx

And that's the end of it.

EDIT:

Also, you don't spawn with any weapons.. and you spawn in the sky.. and the regular TAB menu is there, and none of the menu's work.

I just put the SVN version of ULX on there, and this happens when i type in any ULX command


] ulx
Unknown command: __dsr

You’re apparently spawning in the base gamemode which means something in the gamemode broke (duh, I know). What you need to get are the serverside errors.

Also most if not all of those errors are probably related to the ton of addons you have installed.

lol, i saw that, i was like “holy shit, that is mostly errors on my end.”