Need some help with Ninja Ripper

Hi there!

I am in need of some Far Cry 3 Models, because i am working on SWEPS/Playermodels

Because people aren’t ripping the models i wanted, i decided to do it myself, but with no sucess in the ripping process…

Could someone help me out and show me how to use Ninja Ripper on the game or add me on steam so you could help me out?


Have you tried any other programs like “3D Ripper DX”? Should give it a shot as it works pretty well for what I’ve heard.

I kinda with there was a real OpenGL model ripper on the net as I really need one right now.

Won’t work unless the game uses DX9, which I doubt.

Steam says something else.

Oh yeah, I forgot that you can toggle it for most games.
But still, Ninja Ripper is a better choice since it has the possibility of ripping models in t-pose.

Frankly it’s pretty self-explanatory, but there’s also an official tutorial.

Obviously i tried that tutorial. But either the game wont launch or i get the intruder.dll log error.

I haven’t tried the 3dripperdx because i thought it only supported DX8, but seems im wrong

I am currently giving 3dvia printscreen a shot.

Ill get you back with news

Have you tried the wrappers?

Like i said, the game wont launch. All the wrappers wont do anything.

Also 3dviaprint didn’t do anything, and 3dripperdx makes FC3 crash at the logo when the game starts

I’m not sure if this is possible or not but maybe the game has some type of security that it won’t start if a program like 3dripper is running. It’s just a wild guess that I got when I tried to rip some stuff too and the game didn’t launch so I gave up.

3D Ripper DX messes up the models anyway, rips it in an angle(atleast for me)

and I’ve only got it working on XP

If anyone has been able to extract models from Far cry 3, please hit me up on steam ^^

EDIT: reinstalled Far Cry 3 and the game seems to run now with 3dripper. Testing
EDIT x2: Nope, 3dRipperDX didn’t do anything
I also tried 3dvia printscreen with no avail either.

-snip- db post

Are you actually enabling DX9 mode?

Yes. I set dx9 ingame, but to no avail.

Btw, i am running windows 7 64bit if that makes a difference.

Bumping because i KINDA solved it

Since no other program was working, i decided to attempt to extract Far cry 3’s dat files using Dunia Unpacker, and it was sucessful!

Now i need to find a way to convert the .XBG model files into things like OBJ

Any advice?

I think that might be your problem. Unless I’m mistaken, 3D Ripper DX and Ninja Ripper only function on a 32-bit OS by default (someone please correct me if I’m wrong).

NR works just fine on 64-bit OS, it will Not work in 64-bit processes like the coming Battlefield 4 which is going to be a 64-bit exclusive game.

Is far cry 3 a 64-bit process?

3D ripper DX and Ninja Ripper runs fine in x64 systems, the problem is that both work just in x32 games and programs. I got the dolphin emulator, 3D Ripper DX and Ninja Ripper works fine in x32 version of the emulator, but not with the x64 version, the problem is that the meshes got messed.
I got Win7 x64 bits.

This thread is from august.