.NET Framework 3.5 couldn't be installed

Just bought Rust, finished installing and was prompted that I needed to install .NET Framework. Every time I try to finish installing it, it gives me this message:

I tried doing the “Check Box next to FRAMEWORK 3.5 thing in Turn Windows features on or off” but no luck. Any help would be appreciated. Thanks :smile:

Is this a personal laptop or a shared one? I had issues on my work laptop with Windows 10 and the Group Policy that threw that exact same error code. I still haven’t had it installed because I need to drop it off to IT so they can work some voodoo magic bullshit on it.

This is my personal computer I got about a month ago.

Try this link, it’s not a downloader but the full install package from MS

Getting same error still. :frowning:

Well shit, sorry man =/ that’s all I’ve got

I am starting to lose faith :frowning: I really wanted to play tonight but its not looking likely.

Did you run as administrator?

Yes

Mmm did you try a hammer?