Never thought I would need help for....hosting a listen server -_-

For the astronomically explainable reason, I can host a listen server, but nobody can connect to it. Not public, not even LAN. My roommate can host a server on his laptop and I can connect to it, I host a listen server, and it’s nowhere to be found. Can’t join in friends, can’t join manually through the console, can’t join from LAN tab in legacy browser.

This is what I have done:
Set a static IP for my computer through my routers (Netgear WNDR3400v2) DCHP reservation (currently 156.221.58.151)
Tried enabling/disabling UPnP for the router (apparently having it on has caused issues for other people)
Tried using DMZ on my static IP
Made sure sv_lan was 0, tried using the heartbeat command, and tried changing the IP setting in the console from localhost, to both my local ip (i was desperate), and my public IP from whatsmyip.org, and executed a map change between every command
Used PF Port checker to verify that the port 27015 on TCP and UDP were both open.
The ports forwarded are for both UDP and TCP

http://imageshack.us/a/img11/5407/ipsettings.jpg

http://imageshack.us/a/img211/3497/portforward.jpg

http://imageshack.us/a/img824/378/capturerxj.jpg

WTF IS GOING ON?:suicide:

**
Edit:
**And just for shits and giigles, I can host a CSS server without a problem

Make sure that using TCP AND UDP protocol. So port forward whatever ports you put there already on both TCP and UDP protocols. Not with FTP, as I see there.

TCP is used for RCON, you don’t really need it

The ports you see are forwarded for UDP/TCP, the FTP thing you see is for “quick port forwarding” for the things in the dropdown list
http://imageshack.us/a/img202/132/captureld.jpg

New update, I can run an SRCDS dedicated gmod server just fine with no adjustments, but not a listen server, what gives? If nobody has a solution I’m content with letting this thread die…this has just been rattling my brain for the past week now…

I’ve always wondered which ports I had to forward. I’ve been told 27015, 27016, 27005…do you really need to open 50 ports to get a listen server to work?

I remember back in the day, all I need to forward was 27015 for both TCP and UDP. Then the magic started.

27015 UDP for the server to work, TCP if you want RCON

I tried doing 27015 and it didn’t work. My friends couldn’t see my server at all. I just went ahead and forwarded ports 27000-27050.

that’s silly an unnecessary, you must be forwarding for the wrong internal IP then

Well, before I had it on TCP and UDP. I’ll try just doing TCP but if that doesn’t work, I’m going all out. lol

Well yeah that’s exactly what I did too, the ranges between 27000 and 27050 alternate from UDP to TCP, so I just forwarded the entire range under both, I read somewhere else that there was a different port specifically for servers appearing on the master list, but that didn’t help, and 27015 works fine for everything else. Even under all these conditions, my friends can’t join in the friends tab either, by typing in the IP, or through LAN.

TCP doesn’t matter unless you want RCON

I’m not going to pretend to even know what RCON is. I’m not very educated in the networking arts. I just know about ports and forwarding them.

RCON is basically the servers console.
Try disabling any software firewalls you have temporarily, or add an exception to them.