New Computer - GMod won't load at all

I know I may get some flak for opening this thread, I am aware there are many many many threads asking the exact same thing. Problem is, I’ve spent the last hour scouring through each of the threads and all of the solutions failed to solve my problem… Knowing my luck it’s something very simple and I’ll likely want to kick myself repeatedly afterwards

Basically I press “Play” and the ‘preparing to launch’ box pops up for a split second and then nothing else happens

Any way, my computer specs are as follows (and as far as I’m aware, I have updated all drivers and the usual stuff)


System Information

Time of this report: 2/28/2011, 21:21:53
Machine name:
Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7600) (7600.win7_gdr.101026-1503)
Language: English (Regional Setting: English)
System Manufacturer: System manufacturer
System Model: System Product Name
BIOS: BIOS Date: 05/25/10 14:39:27 Ver: 08.00.15
Processor: Intel® Core™ i7 CPU 950 @ 3.07GHz (8 CPUs), ~3.1GHz
Memory: 6144MB RAM
Available OS Memory: 6136MB RAM
Page File: 2640MB used, 9627MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7600.16385 32bit Unicode


Display Devices

      Card name: NVIDIA GeForce GTX 480
   Manufacturer: NVIDIA
      Chip type: GeForce GTX 480
       DAC type: Integrated RAMDAC
     Device Key: Enum\PCI\VEN_10DE&DEV_06C0&SUBSYS_83591043&REV_A3
 Display Memory: 4063 MB

Dedicated Memory: 1503 MB
Shared Memory: 2559 MB
Current Mode: 1680 x 1050 (32 bit) (60Hz)
Monitor Name: SyncMaster T220/T220G,SyncMaster Magic T220/T220G(Digital)
Monitor Model: SyncMaster
Monitor Id: SAM03E5
Native Mode: 1680 x 1050§ (59.883Hz)
Output Type: DVI
Driver Name: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Driver File Version: 8.17.0012.6658 (English)
Driver Version: 8.17.12.6658
DDI Version: 10.1
Driver Model: WDDM 1.1
Driver Attributes: Final Retail
Driver Date/Size: 1/8/2011 03:27:00, 12859496 bytes
WHQL Logo’d: n/a
WHQL Date Stamp: n/a
Device Identifier: {D7B71E3E-4580-11CF-C372-53A302C2CA35}
Vendor ID: 0x10DE
Device ID: 0x06C0
SubSys ID: 0x83591043
Revision ID: 0x00A3
Driver Strong Name: oem25.inf:NVIDIA_SetA_Devices.NTamd64.6.1:Section005:8.17.12.6658:pci\ven_10de&dev_06c0
Rank Of Driver: 00E62001
Video Accel: ModeMPEG2_A ModeMPEG2_C ModeVC1_C ModeWMV9_C

I’ve tried validating the files, all are “ok”
I’ve uninstalled and reinstalled Gmod fresh
I’ve tried the various launch settings suggestions from other threads I discovered
I even edited the config.text file as suggested in another thread (and replaced it after with the original when it failed to solve the problem)

Not sure what else I can do :frowning: Google doesn’t want to be my friend and the solutions in the various threads aren’t working in my case

If you don’t have any custom shits that you’d be worried about then go to your 2nd garrysmod folder and delete the following folders:

settings
lua
cache
lua_temp

if still not working delete every folder but addons, maps, materials, models, sound.

if still a problem… its one of your addons, go through one by one disabling the addons by making a folder called disabled in addons and dragging them back and forth.

try restarting your pc as well lol.

Thanks for the reply Buggzie, but no luck :frowning: Really have no clue any more

Uhmm, try fragmenting the game or checking if anything is denying hl2.exe from starting

does css start?

I think it might be your video driver, that’s what was wrong when I first installed Windows 7. Do any other games work?

Yep every other game I have on Steam from Half Life 2 and all the various bits like Deathmatch, to L4D, Team Fortress, Black Ops. It’s really weird cause it’s the only game on the list that won’t work and won’t even give me an error message telling me why :stuck_out_tongue:

I vaguely recall many years ago that I had a problem with GMod either starting or crashing at the menu… and I never found a solution back then either. It was only until I bought a new comp years after that it worked again

edit: Just fragmented, still a no go :S

Uh, try downloading drivers from NVIDIA? http://www.nvidia.co.uk/Download/index.aspx?lang=en-uk

Yep downloaded the latest. One of the first thing’s I did was update all drivers

lol :frowning:

Am I looking royally screwed now? :stuck_out_tongue: I really appreciate the help though guys <3

Uh, yeah this is weird. I don’t know what to say anymore.

Delete Clientregistry.blob in your steam folder and restart steam.

You could also try -fullscreen or -windowed

His or her game doesn’t actually start, so changing the size of the window won’t work.

Normally if your game doesn’t start then something is missing, try to re-download garry’s mod after deleteing garrysmod folder and garrysmod .gcf file in your steamapps.

uhhhh

[editline]1st March 2011[/editline]

Next time before you say silly things like that, give a better reason than “it wont work because i think it wont work”.

If the game doesn’t start, how the fuck are you gonna be affect by the window size?

Deleting Clientregistry.blob didn’t work and I’d already tried the window/fullscreen launch options from previous threads I found

LOL I’m becoming a lost cause :stuck_out_tongue:

Did you try sending a support ticket to STEAM?

Antivirus blocking? Is there a hl2.exe process popping up after you’ve started it?

Using AVG Free antivirus. I added Garrysmod to the Resident Shield exception list and still nothing

Yes the hl2.exe process is popping up after I launch GMod

And no I haven’t opened a Steam support ticket yet. When I last had this problem years ago they weren’t very helpful. Unlike you guys :stuck_out_tongue: Thank you all

If you know where you find your Event Log, open the application events list and see if you can glean any extra information from that… you never know, it might just help!

Managed to find it, it entered the log as an error and had this to say for itself;

Faulting application name: hl2.exe, version: 0.0.0.0, time stamp: 0x4d094ebe
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x0018e842
Faulting process id: 0x1770
Faulting application start time: 0x01cbd9fd736c1678
Faulting application path: c:\program files (x86)\steam\steamapps\ghost_darkside\garrysmod\hl2.exe
Faulting module path: unknown
Report Id: b1dbb5bd-45f0-11e0-b362-20cf30558032