New engine

On garrysmod.com,it says that after version 13 that the client error wont happen anymore because of a gmod will be shipping a new engine.

From the website,
If it’s any consolation this won’t happen anymore when we hit version 13 - because we’ll be shipping our own engine.

Yeah, we’ve been talking about the “new engine” for ages now.

I was a late one to gmod.