New GMod update not launching

Ok well,apparently the new Garrys Mod 10 update won’t launch for me.It basically does this (in order):

Preparing to launch garry’s mod 10…window dissapearsand then nothing happens.In simple version:It won’t load up.I really want to play gmod 10 because it is my life! I can’t live without it :smiley:

re install steam or get another fresh version

A lot of people are having this issue. It affects all source engine 2007 games.

Valve’s pretending the problem doesn’t exist so we’re S.O.L.

I already re-installed a lot of times.Why would I need to re-validate/re-install again if it won’t really help? Come on garry,help us out here!

I’m having the same problem.

I cleaned my Gmod folder, and only Gmod is affected.

=(

Same here pleaz help I need Gmod I heve dun every thang and formated to see if it whould help. I Need my game back! I pade $$ for this it is alos my life LoL

I have the same issue… I’ve also uninstalled and removed all steam folders and files then reinstalled it all…STILL NO Gmod. This needs to be fixed.
Win XP
1.5gig T-Bird
2gig ram
100gig idee hd

I’m thinking 1 of the coders forgot to add XP support for the game.
SO? What’s the problem?

Maybe if we ALL call Valve @ the same time for the next 3 weeks they’ll get ahold of Garry and get this fixed. If not we could all carpool to Garry’s house and ask him to fix it ourselves.

Come on garry,don’t force us to buy new computers!You have made Garry’s Mod unstable for the perhaps 25% of people who have my problem and/or cannot buy a new computer yet.Can you please at least make a copy of the garry’s mod 10 downloadable that was before the update?
EDIT:I used a better computer and it launched.However,when I joined a server (not singleplayer),it crashes with Hl2.EXE Had to close.And this happens right after it says "Joining game…"but why would it not let me in if others are in it as well?

Hey Guys,
I’m having the exact same problem & I’m wiping my computer completely clean of steam right now, and now download all the stuff all over again to see if it works at all.
But this problem has been plaguing me, it works on an older outdated computer than what I’m running, well it’s not really outdated … just the video card haha.

I can see we are not going to get help here =’(

I’ve got a possible fix (worked here anyways.)

  1. Close steam
  2. Browse to Windows\System32
  3. Delete steam.dll
  4. Run steam again (let it update if it tries)

After this, GMod (and all of my other Source engine games) worked fine.

Verify integrity. So they know the game is legal. I believe there is a link to that at garrysmod.com if you scroll down a bit.

it was working for me last time i tried to run it, and now it just won’t start. all my other steam games work fine. even reinstalling didn’t help

I had this for ages and it went away with the new April 1 Update!

Has anyone herd anything else about this i just bought the game yesterday only fin that it doesnt work. What BS. It’s not my comp. i run a intell e6850, a nvidia 8800gtx, and a nvidia 680i sli mobo, wit h2 of ram. Please some help with this ive try all solution on this tread.

I really need a fix for this. it only started recently. My friend has a PC similar to mine and his works fine, so i’m pretty sure it’s not my PC

I wanted to try this, but there was no steam.dll. Damn.

Is anyone else getting an error when they open Gmod, it starts launching then just stops and gives the usual windows-style error, “hl2.exe has encountered an error”?

That’s what i’m getting. Cleaning Gmod and HL2 does nothing, for the record.

I Have the REAL Fix (without deleting, reinstalling, etc)

I have had the same problem myself for a couple hours of MADNESS, and fixed it.

Step 1: Load Up STEAM

Step 2: Right Click Garrys Mod And Click “Properties”

Step 3: When A Menu pops Up, Click “Set Launch Options”

FINAL STEP: Now, type “-dxlevel 81” (No Quotes). GMOD Works!

This also works with people who have the error pop up on their screen stating “hl2.exe has encountered an error”, or something related instead of it doing nothing, which was orignally what I had to look up to find this solution. Looks like YouTube saved me again.

i did that but then i figured out that it changes your directx level to 8.1 and then when it launched it really messed up like my res was weird and i tried changing it and it got even worse ):

I got this fucking error too get a fucking fix ffs someone!!!