New help. PLEASE

Hello everybody.

I need your help.

My computer:

Intel® Core™ i3-3110M CPU @ 2.40GHz (x4)
8GB ram
64bit
2 video cards ( dedicated and integrated … ). My better video card is NVIDIA GeForce GT 635M 2gb and the integrated video card is Intel® HD Graphics 4000.

In NVIDIA control panel I have all setting for NVIDIA. In all games I am using a NVIDIA video card, but in Rust when I open a console by F1 and I will click System Information ( or somethink like it ) I can see that I am using a Intel video card. It is reason why I have 20-25 fps in game … Please help me what is it ?!

I can’t change the video card in BIOS.

THANK YOU.

Right-click on the desktop and set the Nvidia as the default graphics adapter in the menus. This will cause your power consumption to go up on the laptop (because now the hungry 635M will be powered on all the time instead of letting the Intel HD draw Windows), but it should help Rust use the right card.

Also go into your power profile and make sure it’s set to High Performance. This will also affect laptop battery life.

I have done it all but Rust all the time is using a integrated video card ;/ I don’t have idea what it can be …

My son and I just started playing, and he had the exact same problem as you on his laptop. (Although I highly doubt you were getting 25fps with onboard graphics!)
I thought I had forced it to use the GPU, but it still didn’t work. I ended up configuring his laptop to use ONLY the GPU for everything. It seems you can’t give Rust a choice or it will choose wrong! In his case power consumption doesn’t really matter since he is plugged in all the time anyway.

if it’s really being picky i would change it in BIOS, but you have specifically said you can’t; why not?

also, make sure your exceptions are for both rust executables, not just one.

In NVIDIA control panel I have settings for both Rust files. I can’t change my video card in BIOS, since when I open the BIOS I can just choose:

  • integrated video card
  • the system will change cards automatically ( I have selected it )

Also, learn from your mistake in buying a laptop as a gaming pc. Not even “gaming laptops” are good for gaming today. There’s either a problem with power consumption, lower end graphic cards or - every specc is good but the design of the laptop gets it so warm the perfomance is getting cut down anyway.

Buy a real pc next time. Even people with a good stationary are having problems optimizing this game… soooo yeah.

interesting. is the nvidia card showing up in device manager?

Yes. I can see NVIDIA in device manager.

BTW. When i uninstalled a Intel video card, Rust didin’t see a video card…

I have all latest drivers for video cards and it all the time doesn’t work.

I should run Rust by directx 9 or 11 ?