New Location of .gma Files?

Forgive me if this has been answered already, I tried search multiple times and it returned a 503 Cloudflare host error.

I used to dev for a server community a couple years ago. After a long hiatus I took from the game, they recently reached out to me again to help migrate to a new NFO rental unit. Upon getting everything copied over and setting up the Workshop collection hosting, I noticed that the server started up very quickly on first launch… quicker than I remembered. I checked the FTP in the Addons folder and saw no .gma files. I looked through the console.log files and saw 100 instances similar to this, counting backward, differing for each addon:



Processing addon 100: Skeleton Player Model (104538509)...
   Addon up to date, mounted!


So I did a server-wide FTP search for files ending in .gma, and what I saw confused me. All of the Workshop files are now located in /garrysmod/cache/srcds instead of garrysmod/addons

Is this the new proper location of gma files? I mean… everything seems to be working fine, so if it’s malfunctioning I can’t really tell. I just can’t find anything through Google (and not here either since search failed me) referencing the change of directory structure for Workshop addon downloads.

-snip- I’m bein stupid.

All of my resource.AddWorkshops are in garrysmod/lua/autorun/server/fastdl.lua as they have been for years. It looks like it’s recognizing and mounting the addons from garrysmod/cache/srcds … but that doesn’t necessarily mean it is in fact working.

I think I’m going to wipe the server and start over with NFO’s defaults, and then only add the collection ID and API key through the Control Panel and see what it does with everything on the defaults.

I also installed a fresh SRCDS from SteamCMD on my personal computer, and it is exhibiting the same behaviour when downloading/mounting addons.

Yes, that is the new place for .gma files on srcds, it is not broken.

Thank you so much! I’ll mark this solved.