New SteamCMD Server Srcds.exe for GMod wont start

Whenever trying to launch srcds.exe for a Gmod dedicated server it wont launch.
I have installed the server using the new SteamCMD command prompt.
One time it did launch and I also have launched it using administrator privileges (with no success), so I doubt Windows 8 is the problem seeing that it worked before the steampipe update.
It shows the pointer with the loading ring for a moment then does nothing.
I used the commands:


login anonymous


app_update 4020

Your help would be greatly appreciated :dance:

You can’t just open srcds.exe and it will run the server, you have to provide commands for it.

Create a start.bat file in the same dir as the srcds.exe and add these contents to it:



srcds.exe -console -game garrysmod +map gm_construct -port 27015 +maxplayers 16


Then launch the start.bat script and your server should start up.
If your friends have issues connecting, here’s the link for that! Google

Why did it work before without me having to do this?

I was confused because the first time I started the server and it worked it brought up the old srcds UI. Thanks for the help! :smiley: