Nexus Schema Problem

I finished my schema of kuro’s Nexus gamemode, set up MySQL and all that stuff. The quiz works fine, but when I get to character creation, a derma tab pops up with settings and a button that says ‘Continue’ below it. I press continue, but nothing happens. Solutions?

buy open aura…

The database isn’t installed correctly or another error occured, check your error logs.

I’ve tinkered around with MySQL database, but I do get this error in console.

[repens\gamemode\schema\cl_hooks.lua:34] attempt to compare nil with number

I’ve heard of others who have the same problem, they cannot continue past attributes.

post the block of code with the error and label which line is 34

function SCHEMA:PostDrawOpaqueRenderables(drawingDepth, drawingSkybox)
if (!drawingSkybox) then
local colorWhite = nexus.schema.GetColor(“white”);
local colorBlack = Color(0, 0, 0, 255);
local eyeAngles = EyeAngles();
local curTime = UnPredictedCurTime();
local eyePos = EyePos();

	if (curTime >= self.nextGetSnipers) then -- Line 34
		self.nextGetSnipers = curTime + 1;
		self.sniperPlayers = {};
		
		for k, v in ipairs( g_Player.GetAll() ) do
			if ( nexus.player.GetWeaponRaised(v) ) then
				local weapon = v:GetActiveWeapon();
				
				if ( v:HasInitialized() and IsValid(weapon) ) then
					local weaponClass = string.lower( weapon:GetClass() );
					
					if (weaponClass == "rcs_g3sg1" and weapon:GetNetworkedInt("Zoom") != 0) then
						self.sniperPlayers[#self.sniperPlayers + 1] = v;
					end;
				end;
			end;
		end;

nextGetSnipers is nil, so you didn’t get the entire script or it’s broken.

It can’t be broken, I know that much. What if I remove the block of code?

why wouldn’t it be broken? It’s very common upon leaked scripts. Find all instances of that function in the code and try to find the issue…

Okay, I’ve found that the uniqueID of my G3SG1 item is wrong, related to the code, as well as the item name. I think that is the issue.

[editline]13th January 2011[/editline]

I changed the uniqueID and all that stuff in the item code. I removed rcs_g3sg1 from the RCS addons, and removed the item, I still get the issue.

I removed the block of code and fixed most issues, however I still get four which I will post below.

[gamemodes\repens\gamemode\schema\sh_coms.lua:142] unexpected symbol near ‘}’

OnGive = function(player, storageTable, itemTable)
if (player:GetCharacterData(“clothes”) == itemTable.index) then
if ( !player:HasItem(itemTable.index) ) then
player:SetCharacterData(“clothes”, nil);

										itemTable:OnChangeClothes(player, false);
									end;
								CanTake = function(target, storageTable, item)
								local itemTable = nexus.item.Get(item);
								local team = player:Team();
							end;
							CanTakeCash = function(target, storageTable, cash)
							local team = player:Team();
								
								if (team == CLASS_POLICE or team == CLASS_SPECIALTYUNIT
								or team == CLASS_ADMINISTRATION or team == CLASS_DOCTOR) then
									nexus.player.Notify(player, "You can only take illegal items as a government class!");
									
									return false;
								else
									return true;
								end;
							end
						} ); -- Line 142
					else
						nexus.player.Notify(player, "You are already searching a character!");
					end;
				else
					nexus.player.Notify(player, "You cannot search a moving character!");
				end;
			else

[gamemodes\repens\gamemode\schema\entities\weapons
x_flashgrenade\sh_auto.lua:98] function arguments expected near ‘=’

function SWEP:Holster(switchingTo)
self:SendWeaponAnim(ACT_VM_HOLSTER);

    self:PulledBack = nil; -- Line 98
    self:Attacking = nil;

    return true;

end;

function SWEP:GetRaised()
local curTime = CurTime();

    if ( self.Attacking or (self.Raised and self.Raised > curTime) ) then
            return true;
    end;

end;

[gamemodes\repens\gamemode\schema\directory\cl_roleplay.lua:105] ‘)’ expected (to close ‘(’ at line 6) near '[[<font size=“4” color=“white” face=“Times New Roman”>
<center><b>Guidelines and Roleplay</b></center>

nexus.directory.AddCategoryPage( “Guidelines and Roleplay”, nil [[ – Line 6

]] ); – Line 105

[nexus\gamemode\core\libraries\sh_class.lua:12] attempt to index local ‘data’ (a nil value)

function nexus.class.Register(data, name)
if (!data.maleModel) then – Line 12
data.maleModel = data.femaleModel;
end;

if (!data.femaleModel) then
	data.femaleModel = data.maleModel;
end;

It would be very helpful to use [ lua] [ /lua] tags. Also, for line 98, you cant use the colons unless you are calling a function with (), so remove them and replace them with a period. And for line 142 remove the bracket, }.

Thanks mate.

I have fixed most issues, and now I can get past the character creation to attributes, but cannot continue past that.

http://buy.cloudsixteen.com - piracy is against the rules on these forums.

Where does it say that? & How is that piracy? It was a public release a one point… was it not?

Don’t mean to be rude by the way, I’m just being realistic.

It was not a piracy mate, it was public, I do remember that.

Too bad that page times out and “Ideal”-Hosting is still down (how long has it been now? three days?)…

All of my classes have this error in both client and server side.

[gamemodes\repens\gamemode\schema\classes\sh_specialtyunit.lua:16] attempt to index field ‘class’ (a nil value)

[lua]

CLASS_SPECIALTYUNIT = nexus.class.Register(CLASS, “Fort Tiburon Specialty Unit”); – Line 16

[/lua]

In libraries the correct format is “nexus.class.Register” as I have put.

Pretty sure Earth is using skeleton, kuro.
Also reported alt of pb’d user

Side note for kuro’s buddies at ideal hosting “the company”.

Skeleton is open source and was released by Conna for no charge.

Source: http://www.facepunch.com/threads/933051-nexus-Skeleton?highlight=Nexus

Nice try kuro