No Content Servers Problem in Garry's Mod 9

Ok So I start Up Garry’s mod 9 and it goes to the loading screen with the paint can and stuff then it turns off an a pop up comes saying exactly this:

MountFilesystem(241)failed:
SteamMountFilesystem(19096,241,0x155cfc64=,0x155cfd64)failed with error 5: No Steam Content Servers are availible

here is my computer info

768 MB Ram
Windows Vista
NVIDIA GeForce 6100 nForce 405 Video Card
AMD Athlon 64 3800+ Processor

Whats the problem can anyone help?

did you try paying for gmod?

Get Gmod 10.

The problem is that Gmod 9 isn’t regularily updated like Gmod 10.
All your Source games are slowly being updated making Gmod 9 more and more obsolete. So just save up :10bux: and get Gmod 10

That’s odd…

But why are you playing GMod 9 when there is GMod 10. The only way to fix GMod 9 questions is to get GMod 10.

GMod 9 is very unstable. It can’t even work on multiplayer properly and it’s addons make it even worse.

GMod 10 on the other hand… is a lot more stable than GMod 9… but still unstable compared to other source games. But it’s a mod, and to me, I’m very satisfied with what I have in GMod 10 already.

It means it couldn’t mount one of the files. But like many people have said you’re best getting gmod 10. Gmod 9 is like a program in early alpha.

Put this line in the properties of the launch icon for gmod9.
rt click of the icon for gmod9,
select properties,
click in the target box and add this line and change the x to
what ever your drive name is: like c:.

x is the directory name for me instead of c:\

X:\HalfLife\steam.exe -applaunch 215 -game “x:\halflife\SteamApps\SourceMods\gmod9”

I just tested this and my gmod9 works fine.
I hope this helps.

I tried that and it doesnt load now
im using C:/ to play steam but, i have steam on a sepperate drive.
So do I use

C:\HalfLife\steam.exe -applaunch 215 -game "x:\halflife\SteamApps\SourceMods\gmod9
or
T:\HalfLife\steam.exe -applaunch 215 -game "x:\halflife\SteamApps\SourceMods\gmod9
?

You um bumped an 8 month thread for something that is not supported,also that you should not post this on these forums for it post to be GMOD 10

Hello. Your problem is your gameinfo.txt
Go to C:\Program Files\Steam\steamapps\SourceMods\gmod9\gameinfo.txt
On line 23 the code should say this:


SteamAppId				215		// This will mount all the GCFs we need (240=CS:S, 220=HL2).

Not


SteamAppId				220		// This will mount all the GCFs we need (240=CS:S, 220=HL2).

This will disable ALL Half-Life 2 content. To re-enable the Half-Life 2 content wirte a “content.txt” file in $GMOD9DIR\cfg\content.txt (Write new) and put in it this:


"Content"
{
	"240"
	{
		"mount"		"1"
	}
	"220"
	{
		"mount"		"1"
	}

	"300"
	{
		"mount"		"1"
	}
	"380"
	{
		"mount"		"1"
	}
	"420"
	{
		"mount"		"1"
	}
	"400"
	{
		"mount"		"1"
	}
	"440"
	{
		"mount"		"1"
	}
	"340"
	{
		"mount"		"1"
	}
	"280"
	{
		"mount"		"1"
	}
	"360"
	{
		"mount"		"1"
	}
}


Hope this fixes your problems.
-JD

I had this problem before I moved onto gmod 10. Its because you dont have counter strike: source installed. I read about it too.

Garry’s Mod 9 is no longer supported on these forums. The answer would be to get GMod 10.