No dynamic shadows.

Like the title said,ever since I got my new PC,dynamic shadows are practically non-existant in my G-Mod now. It has shadows on the ground casted by a model though but when ex. shining a lamp on a ragdoll/object against the wall,there’s no shadow casted on the wall. Also I should mention that there’s no high setting in the shadows option.

It couldn’t be a graphics card problem since I am able to render extremely sexy shadows in Metro 2033,Call of Duty,Battlefield,Crysis 3 etc. This problem only happens in Source games mainly Garry’s Mod. If someone can give me a solution to fix this,I’d be very delighted.

These are my two display adapters btw:
Intel HD Graphics 4000
AMD Radeon HD 7670M

Bump. Any solutions?

BUMP
Aw come on guys,don’t tell me there are absolutely no solutions for this problem?

Someone else is having this issue too. So far, no one has a solution

Having it too for some reason.

Someone found the solution.

For anyone that still has this problem even after adding -dxlevel 90 as a launch option, try typing “r_shadows 1” into the console.