No "High Shadow" option

So yeah, I have a really annoying problem that I cant fix it.
The problem is that I don’t have the High option in shadows,

How do I add/fix it?

Put -dxlevel 95 in your startup parameters.

It still doesn’t work.

Tried turning off Windows Aero extensions? What are your specifications?

Yeah ive tried turning off Windows Aero extensions, and it still doesn’t work.
And my specifications are:
Intel Core i7 - 3630QM, 2.4GHz
16GB of RAM
Windows 8.1
HDD 128GB SSD + 750GB
Nvidia GTX 660M - 2GB
ASUS Laptop G46V

Your hardware level says DirectX 8; your graphics card doesn’t support 9.

So how do I fix it?

It says it supports up to DX 11.1 online, so try updating your DirectX.

Ive updated it, Still doesn’t work…

Have you updated your graphics card drivers yet?

I’ve finally found how to fix it!
Just follow those instructions:
•Go to the “Library” menu in Steam.
•Go to any Source game’s Launch Options. (Right Click on the game > Properties > Set Launch Options)
•Copy and paste this in the Command Line: -force_vendor_id 0x10DE -force_device_id 0x1180

Thanks for Ninjaman349 for finding it! :dance:

That only works if you have another graphics card, specifically integrated. Also, vendor ID’s are not static across all cards.

Out of curiousity, do you have DirectX 9.0c installed?

Yeah