No Hud/GUI for NVIDIA (Possibly radeon) Fix for Mobile users With Multiple GPUs ex: 635m/Intel Hd 4000

32 Bit: Install firefox https://download.mozilla.org/?product=firefox-stub&os=win&lang=en-US and Unity Web Player 32 Bit http://unity3d.com/webplayer

64 Bit (More optimized browser): Install waterfox http://www.waterfoxproject.org/ and Unity Webplayer 64 bit http://webplayer.unity3d.com/download_webplayer-3.x/UnityWebPlayerFull64.exe

After installing these install nvidia 314.22 drivers due to 320.49 breaking the nvidia control panel which is vital to this fix (make sure to choose your product here) http://www.nvidia.com/Download/Find.aspx?lang=en-us

When you finish installing these two go to the nvidia control panel by right-clicking on your desktop and selecting then nvidia control panel dialog

This is where it gets interesting.

Now go to Manage 3D Settings and Then click on Program Settings.

32 Bit users click on the 1st dropdown menu and choose firefox and select the default graphics processor to your nvidia driver then the plugin container.exe and select the default graphics processor to your nvidia driver.

64 Bit users click the add button next to the 1st dropdown menu and choose waterfox and select the default graphics processor to your nvidia driver then the plugin container.exe and select the default graphics processor to your nvidia driver.

Hit Apply.
Close out of the nvidia control panel.
Go to playrust.com
Login.
Hit playgame.
If you see the Rust Logo in bright blue then you fixed your game.
If you do not you did it wrong OR this may not be the fix for you but this should be the fix for most people.

bump to front


(User was banned for this post ("Don't post contentless bumps" - MaxOfS2D))

Downloading the drivers right now, will let you know if this works.

[editline]12th July 2013[/editline]

Well I have a Geforce G210M and I chose it in the dropdown menu but:

http://puu.sh/3Bztl.png

look for a compatible driver that allows you to change graphics card in the control panel

Some laptop manufacturers have a hybrid solution that switches between a weak but power-efficient chipset (usually Intel ones) and a more powerful video card. Sadly for some of these manufacturers, their custom modified drivers are required; you can find them on the laptop’s manufacturer support website

Yeah turns out I have some Power4Gear Hybrid thing. Got the latest drivers from Asus (2009 was the most recently updated).

My Nvidia control panel looks like this:

http://puu.sh/3BBdE.png

No option to force it to use the Nvidia GPU so I guess I’m stuck.

[editline]12th July 2013[/editline]

Well this is as far as I get before Unity crashes. If anyone has any idea on how to get this working, please let me know.

http://puu.sh/3BBu3.png

did anyone figure anything out for intel cause all i see is intel does not work at all unless u are on mac

Does anyone have any way to fix the HUD on Radeon?

Could try updating/rolling back to previous drivers :).
Worked for a couple of people.