No Idea on what is wrong with my SENT

Made a test SENT but it’s getting removed on spawn due to “Crazy Physics”
Error:


Crazy physics on [80][testent] [Ang:-1.#IND00,1.#QNAN0,180.000000] [Pos:448.000000,576.000000,-12223.482422] - removing

here’s the SENT code and spawning concommand:


if SERVER then AddCSLuaFile("shared.lua") end

ENT.PrintName = "test_ent"
ENT.Model = Model("models/props/cs_office/microwave.mdl")

function ENT:Initialize()
   self:SetModel(self.Model)

   self:PhysicsInit(SOLID_VPHYSICS)
   self:SetMoveType(MOVETYPE_VPHYSICS)
   self:SetSolid(SOLID_BBOX)

   local b = 32
   self:SetCollisionBounds(Vector(-b, -b, -b), Vector(b,b,b))

   self:SetCollisionGroup(COLLISION_GROUP_WEAPON)
   if SERVER then

      local phys = self:GetPhysicsObject()
      if IsValid(phys) then
         phys:SetMass(200)
      end

      self:SetUseType(SIMPLE_USE)
   end

end


function ENT:Use(ply)
   ply:ChatPrint("hey")
end

---------------------------------------------------------------------

if SERVER then

	concommand.Add( "spawntest", function(ply, cmd, arg)
		if not IsValid(ply) then return end
		
		local testent1 = ents.Create("testent")
		if IsValid(testent1) then
			testent1:SetPos(ply:GetShootPos())
			testent1:SetAngles( Angle(0, 0, 0) )
			testent1:Spawn()
			testent1:PhysWake()
		end
		
	end )

end

I had this issue once when I spawned something inside the world, does this also happen when you spawn it in an area that you know of that there is nothing there?

yes I’ve tried with my own position in noclip mid air