No materials. Purple checkers of death.

It’s pissing me the fuck off. I followed a tutorial about it, and I got the .qc and .smd to work. It creates it as normal, but my texture is missing. I’ve tried changing directories at least 10 times, and nothing works. yes, the cdmaterials is set to materials/models.

qc file (ignore formatting shit):

$modelname “props_tower/worldtowersign.mdl”
$body mybody “worldtowersign.smd”
$staticprop
$surfaceprop “metal”
$cdmaterials “materials/models/”
$upaxis “Y”

$sequence idle “worldtowersign.smd” loop fps 1

$collisionmodel “worldtowersign.smd” { $concave }

anyone know of any fixes? no, im not going to go to the mega-thread. it’s like an abandoned whore. no.

Is the name of the .vtf the same exact as the image applied as a texture to the model before exporting? The .vmt and .vtf should have the same name as the image applied to the model otherwise the .vmt will be trying to read the wrong texture.

yes

Could you post the .VMT?

After you post the VMT, make sure that “worldtowersign” is the name of the material referenced in the actual model you made.

$cdmaterials “materials/models/”

If I’m not mistaken, this is your problem. Remove “materials/” and should be fine.

E.g
$cdmaterials “models”

Riiiight…! Totally did not notice he did that.
$cdmaterials assumes the root directory for materials is “materials”, just like $modelname assumes the root directory for models is “models”.

derp. thanks guys. i love you all
a winner for you all

[editline]June 13[/editline]

edit: shit didnt work. D: i recompiled still getting this

if i attach a .zip, can someone fix the directories for me? ive tried EVERYTHING.

Send it to me if you want. Use www.yousendit.com if you want.

Also, check your .vmt file. Make sure you haven’t done the same thing. I would personally put any custom textures in it’s own folder. I usually create a folder named the name of the map it’s for. And make sure you have put “VertexLitGeneric” and not “LightmappedGeneric” as this is required when your texturing a model.

Change this as you require for your texture:



VertexLitGeneric
{
	"$basetexture"	"models/"

}




$modelname	"props_tower/worldtowersign.mdl"
$body mybody	"worldtowersign.smd"
$staticprop
$surfaceprop	"metal"
$cdmaterials	"models/"
$upaxis "Y"

$sequence idle	"worldtowersign.smd" loop fps 1

$collisionmodel "worldtowersign.smd" { $concave }