No Menu or console in Experimental | Legacy works fine

Hey guys,

I’m new in your forum. I went through some threads and I think you are doing a good job in helping people.

But I haven’t found a solution for my problem. I hope you can help.

Problem:
I can start Rust via steam. It shows me the window with the display solution. When I continue and start the game, then after a short while the background (snowy landscape, two blue crystals, part of a coast…) appears. It’s animated and snow is falling. After that nothing more happens. No reaction on F1 or ESC or ENTER. I can just close it with ALT+F4.
Legacy instead works fine. No problems.

What I have tried:

  • waiting to fix itself…
  • reinstall Rust
  • reinstall steam
  • reinstall DirectX (the one in the rust folder)
  • run Rust.exe or/and RustClient.exe directly
  • run Rust in Admin-Mode
  • disable AVIRA antivirus
  • changing the BETA-Mode in the Rust-properties to development
  • sfc scan
  • window-mode / fullscreen-mode
  • low quality / high quality

nothing helped to show me a menu…

My System:
i5-2500K, 8GB RAM, NVidia GTX580 with 344.48
AVIRA, TuneUpUtilities, ThreatFire (second opinion anti-malware), Secunia PSI (keeps programmes updated) always running in background

I’m happy for any suggestions.

oddly im having the same thing happen but in legacy.

I’m having the same problem, though mine tends to do this strange CD skipping sound and other times it just hangs there like a screen saver playing the sounds and animating the snow…

I’ve also tried just about everything you have done as well…no luck yet, oddly sometimes the menu appears and i get into play yet the game freezes periodically until finally it just freeze crashes.

It sucks but i guess all we can do is wait until a patch sorts it out

You are right… especially with this strange sounds…

I also hope for a patch and that suddenly it will work.

i got mine to work, oddly it was by downloading Malwarebytes program, searched for malware, found some got rid of em, Rust worked…

I also ran Malwarebytes, but it found nothing and Rust is still not working