No menu text (backgroud displays fine)

Hi,

I’ve been running rust legacy without problems for a while now on both a laptop and desktop computer, both running Debian Linux (stable release, fully updated).

When I try to run the current stable version (used to be experimental), the game seems to start normally, The background gets loaded (used to be the one with the wolf, now its the new snowy one) but no text appears. I’ve tried clicking all over the place to see if the buttons were just invisible but this does not seem to be the case. I am also unable to open the console and hence I can not play the game.

As I said I tried it on two different machines who are both able to run rust legacy and should also have the hardware for the current stable. (i7 proccessor, 8gig memory reasonably good nvidia card.)
The installation was done through steam and I have tried both running it directly from steam and outside of steam. I tried different resolutions, windowed vs non-windowed mode and different graphics settings. The result is always the same, the game loads quickly but I get stuck with just the menu background (including the animations, the game is not frozen).

Both computers run the current stable release of Debian Linux and are completely up to date. They are both 64 bits installations.

If you need any more information, please let me know. I looked at enabling some kind of logging to get more info but haven’t figured out if this is possible.

Any help would be greatly appreciated!

bump…

Am I the only one experiencing this game-breaking problem?
If you don’t know how to solve it but know if it is possible to enable extra logging or something similar so I can at least get some idea what the problem is, please also leave a reply.

Hey blaat,

Still being plagued? I am having the same issue on Arch Linux x64 with an nvidia card.

Rust normally keeps it’s player.log in one of the sub-folders of ‘~/.config/unity3d/Facepunch Studios’.

There used to be a ‘-logfile’ or ‘-logFile’ option in Legacy to output a bit more info but I don’t know the state of this option in Experimental.

However in Steam you can set the launch option of Rust to something like this to save the console log to a file: ‘%command% > ~/rust.log’.

Here is a link to my output: http://pastebin.com/4n9SB2dY

I suspect this is a CoherentUI compatibility issue with linux but the warnings and errors I get are like this:


WARNING: Shader Unsupported: 'Hidden/NoiseAndGrainDX11' - Setting to default shader.
[Coherent UI] (Warning) PID: 29188 | 29206 15:29:17.957771 [29188:29206:WARNING:proxy_service.cc(888)] PAC support disabled because there is no system implementation
[Coherent UI] (Warning) PID: 29188 | 29188 15:29:19.003864 Requesting resource read for file:////home/hyshka/.config/unity3d/Facepunch Studios LTD/Rust/cookies.dat with internal id 0 reported FAIL
[Coherent UI] (Warning) PID: 29188 | 29188 15:29:19.078400 [29188:29188:ERROR:child_process_launcher.cc(326)] Failed to launch child process

You can also use this command in a terminal to quickly scan your files for errors or warnings: cat ~/rust.log | egrep -w ‘WARNING|ERROR|Warning’

Hope this helps, let me know what you come up with.