No one can join the server as it gets stuck on "sending client info" Need help!

For some odd reason no one is able to join the server as everyone that tries just gets stuck at “Sending Client Info”. This doesnt happen all the time, only when certain maps are on. All the maps that cause it used to all work fine about 1 week ago (was there an update?) so it a bad map. It might be a bad map/gamemode mixture. As far as I’m aware, there are no errors being thrown.
I’m just wondering if there is a general cause for it to get stuck at “Sending Client Info”. I honestly have no idea why it would get stuck there.

Uh, I’ve been having this trouble back some moths ago. But it dissapeared.

I used to get this occaisionally but just restarting the server fixed it.

There was a thread about this on the TTT forum, where others had this problem too:

http://www.zombiemaster.org/smf/index.php?topic=10580.0

http://www.facepunch.com/threads/1040884-Server-issue-map-changes-and-people-can-t-get-past-client-info.?p=26904064&viewfull=1#post26904064

You might have to add -verify_all to your updater command line.

Thanks I’ll look into those. Hopefully it will fix the problem. I’ll let you know if they do or dont work.

The update worked! Thanks