No one except me can join my dedicated server

Note : Not sure if this is where to post this. (I know there’s similar posts but most of them didn’t work for me.)

EDIT2 : So, i checked my ports once again, and now they’re open…? o.O

So, I made a dedicated garry’s mod server yesterday, installed DarkRP on it, added some addons, portforwarded port 27015. (Used a port checker tool to see if it was portforwarded, it was.)
And today i decided to test it with some friends, and none of them could connect. (failed after 4 retries error), I can’t see anyone connecting in my console.
No errors or anything, it just doesn’t want anyone except me to connect.
I’ve tried to do “sv_lan 0”, with no success.
I’ve also removed my firewall, no success.

I know that my router has a firewall too apparantly, but i have no idea if i should turn it off, and i don’t know how to do it either.
My firewall is controlled by Norton Antivirus, and i have the firewall “offline”.

Here’s what my start.bat file looks like :


@echo off
cls
echo Protecting srcds from crashes...
echo If you want to close srcds and this script, close the srcds window and type Y depending on your language followed by Enter.
title srcds.com Watchdog
:srcds
echo (%time%) srcds started.
start /wait srcds.exe -console -ip -game garrysmod +gamemode darkrp +map rp_downtown_evilmelon_v1 +maxplayers 16
echo (%time%) WARNING: srcds closed or crashed, restarting.
goto srcds

Anyone knows what could be causing my problem? :slight_smile:


(User was banned for this post ("wrong section." - postal))

Well, you need to give them the proper IP. If they just click “join” on you, then they’re joining the internal IP, which obviously only works if they’re on your network…

Not sure what you mean…

Type “My IP” into Google.

Oh… ok.

[editline]20th July 2015[/editline]

I also noticed that my server isn’t listed in the “darkrp servers” list.