No phys or tool gun in gmod.

When i start a game i have no hazard suit, weapons, or phys and tool gun. I’m not sure what is causing this since i haven,t installed any mods or addons recently. If anyone has any ideas, I would apreciate it.

Edit

 I think it has something to do with this error.

ERROR: GAMEMODE:‘PlayerSpawn’ Failed: sandbox/gamemode/init.lua:40: stack overflow

edit
I searched through the init.lua file and found the commands to spawn the stuff i need but was still hoping for a fix.

If anyone els has this problem the commands are “give weapon_physgun” and “give gmod_tool”

I’m confused… What?

This will allow you to spawn the items your missing without having to mess with the console.

Also for you alphaspida;
shut the fuck up and quit working on your (this is a relative term for you) smartness.

Thanks for the help. ASO for you, shut the fuck up and quit being an (this is relative term for you) ass hole.

Do a “find all posts” on the guy you’re defending and you will see that the majority of his posts are less than 3 words, completely unhelpful, and most often rude. I don’t know if you are familiar with post-count padding or general forum etiquette but it’s pretty well understood that this kind of behavior is to be discouraged.

Do your research before you decide to defend someone. Otherwise it can be easy to end up on the wrong side of things.

You’re welcome by the way.

http://forums.facepunchstudios.com/showthread.php?p=10389959

This thread will explain what’s going on with the overflow error, and how to fix it in any gamemode that derived from sandbox. A download of a fix for Spacebuild2 is provided as a sample to show that the fix does work.

Thank you, i had this problem to, i could get the phys gun and not the tool gun. Thank you for command.

by the way delwyn, i had gmod running while installing your fix, it crashed it.
This normally does not happen. just curious.

P.S. I think psycho has a point dude.
please ignore the smartness points…

Hello guise!

wow, he wasn’t even talking about you. He was sticking up for you and gave you the answer to your question (this is the relative term for you) BAD READING.

All you do is.

1: Go to Options>Advanced Options>Enable Developers Console.
2: Go to console should be “~” Under the ESC button.
3: type in “Sv_Cheats 1”
4: Type in “Impulse 101” For the weapons
5: Type in Give gmod_physgun/Give gmod_toolgun.
Done!


(User was banned for this post ("Dumb bump" - postal))

hey, thanks for telling them THREE years later…