No response from Remote host. Help

For the past 2 months i’ve been trying to play the new version and i keep getting a no response from remote host error. Ive tried multiple times on multiple days on multiple servers, Deleted local content and re installed, and my brother is sitting behind me playing it no problem. Does anyone have a little insight to help me out? I really wanna play the new version. Thanks :smiley:

Can you see the server list? What Internet Security are you using?

I can see the list. Im using windows firewall, but ive tried disabling it and running rust, to no avail.

is EAC installed?

It should be. I was prompted to install it when I first ran Rust.

Hey, if you want I could assist you remotely - would need you to download this: http://download.teamviewer.com/download/TeamViewerQS_en.exe and give me the ID and password it gives you in a PM - would let me get a better view of things. Just be warned if a random person offers this as it will give him/her total control of your PC - this would be at your own risk - but I can gaurantee I can help you as i work as an IT Technician - will show my portfolio if requested

The same problem. Can you advise how to solve it?