No servers appear in Default Rust branch

I have been trying to play the new version of rust which went live a couple of weeks ago. However, when I launch the game under any of the beta tabs, no servers appear. I tried doing many things such as deleting the whole folder and starting from scratch.

https://lh4.googleusercontent.com/2c2Rv--8cRRijxsN1cN1QsJQICsSWwY-vjckRDLMgBKVXiA0txar2cmZtG_lEYHnqbvJTFUMbZw=w1341-h552

here is a screenshot of the server browser

thanks for the help!

Hey. You have to start the RustClient.exe as an Administrator. That works for me … but maybe the anticheat tool makes then Problems … But i have the problem that i will be droped from all server after 10 sek of playtime

Thank you so much. I have been searching for hours, and you finally gave me the solution.
Thanks again

UPDATE: I now cannot stay in any server longer than 20 seconds withe the error Disconnected: Easy Anti-Cheat

y this is the same problem that i have :wink: … sry i havent an answere for that :stuck_out_tongue:

Hi,

If you run the game from RustClient.exe, the anti-cheat is never loaded and you cannot play on secure servers.

Are you using Bitdefender by any chance? It is unfortunately known to silently block internet traffic without visible notifications. If if you are on Bitdefender, please try if the help in bottom of this page helps: http://www.easyanticheat.net/support

Ok thx … that works for me :wink:

I found the solution!

right click RustClient.exe, go to compatibility
click change settings for all users, click run as administrator there,
click apply and launcher through steam. I will probably make a guide on this later.