No servers showing up in server list

Specs: Win 7 64 bit
Ram 6g
Processor intel core i7 cpu
Video Card Nivda gtx 580

When i start up Gmod and say refresh server there’s nothing

Check Filters, Close Internet bowser, Spam refresh button?

Nope, didn’t work

Try in your steam and not in Gmod.

[editline]30th December 2010[/editline]

It’s a common bug that no server shows up in gmod but shows up in the steam server browser.

I can see it in steam but if i try to connect it gives me the tried 4 times error

Don’t suppose you’re using a firewall?

That’ll be the exact problem. He’ll have 27005, 27015-27020 blocked.

My firewalls off

Do you have a Belkin router? If so, you need to get to the router configuration page, and you need to disable your router’s firewall. This happened to me with Belkin.

Nope

Open ports 27005 and 27015-27020.

On what my firewall? because its not enabled and i have a dmz on my router so all ports are open

Please? anyway to fix this?

EDIT: Magically started working again

All firewalls are off? Including ones from virus protection or other 3rd party firewalls? If there are no firewalls, possibly a virus?

Could you post your steak community URL page? Sounds like a :pirate:

And, the problem is back. i have no idea whats going on

EDIT: Here you go http://steamcommunity.com/id/Holysmokes/

EDIT2: Just to recap I press refresh and theres no servers and if I try to join a server I get “Connection failed after 4 retry.”.

Same Problem.
I have opened my ports and disabled ALL firewall shit, even anti-virus and router firewall etc…

But still… i can only find 22 servers and all servers in my fav list, but if i try to join them, i keep getting ‘Client timed out’ and that is UNfixable (since i tried almost everything).

Problem again

EDIT: heres the port check

bump

bump

Edit: Here is the firewall on my router and port foward