No-solid player model HELP!

Hello everybody! I have rigged a player model but I have a big problem, the model is’nt a ragdoll, he is no-solid model! I use Studiocompiler to made this, and here is my QC file:

$cd “C:\Users\Léo Dalecki\Desktop actreb\decompile”
$modelname “player\Tactical_Rebel.mdl”
$model “Studio” “gasrebel2.smd”

$cdmaterials “models\gasmask ac_rbe”
$hboxset “default”
$hbox 1 “ValveBiped.Bip01_Head1” -1.250 -6.500 -3.190 8.250 3.500 3.310
$hbox 4 “ValveBiped.Bip01_L_UpperArm” 0.000 -2.750 -2.750 12.510 1.750 2.250
$hbox 4 “ValveBiped.Bip01_L_Forearm” 0.000 -2.190 -2.380 13.000 1.810 1.620
$hbox 4 “ValveBiped.Bip01_L_Hand” 0.060 -2.000 -1.500 4.060 1.000 2.500
$hbox 5 “ValveBiped.Bip01_R_UpperArm” 0.000 -3.000 -2.250 12.390 2.000 2.750
$hbox 5 “ValveBiped.Bip01_R_Forearm” -0.500 -2.200 -1.550 12.500 1.800 2.450
$hbox 5 “ValveBiped.Bip01_R_Hand” 0.060 -2.000 -2.500 4.060 1.000 1.500
$hbox 6 “ValveBiped.Bip01_L_Thigh” 0.000 -3.750 -3.250 17.850 3.750 3.250
$hbox 6 “ValveBiped.Bip01_L_Calf” 0.000 -3.510 -3.280 15.640 3.490 2.720
$hbox 6 “ValveBiped.Bip01_L_Foot” -1.070 -2.000 -2.840 5.040 5.000 2.160
$hbox 6 “ValveBiped.Bip01_L_Toe0” -0.500 -3.000 -2.190 2.500 0.000 2.460
$hbox 7 “ValveBiped.Bip01_R_Thigh” 0.000 -3.750 -3.250 17.850 3.750 3.250
$hbox 7 “ValveBiped.Bip01_R_Calf” 0.000 -3.510 -2.820 15.640 3.490 3.180
$hbox 7 “ValveBiped.Bip01_R_Foot” -1.060 -2.010 -2.280 5.050 4.990 2.720
$hbox 7 “ValveBiped.Bip01_R_Toe0” -0.500 -3.000 -2.600 2.500 0.000 2.100
$hbox 3 “ValveBiped.Bip01_Pelvis” -7.500 -5.500 -6.000 7.500 8.500 5.000
$hbox 2 “ValveBiped.Bip01_Spine2” -2.500 -2.500 -7.000 14.500 7.500 7.000
$attachment “eyes” “ValveBiped.Bip01_Head1” 3.79 -3.78 0.01 rotate -0.00 -80.10 -90.00
$attachment “mouth” “ValveBiped.Bip01_Head1” 1.00 -5.70 0.00 rotate -0.00 -80.00 -90.00
$attachment “chest” “ValveBiped.Bip01_Spine2” 5.00 4.00 -0.00 rotate -0.00 90.00 90.00
$attachment “forward” “ValveBiped.forward” -0.00 -0.00 0.00 rotate 0.00 -0.00 0.00
$attachment “anim_attachment_RH” “ValveBiped.Anim_Attachment_RH” 0.00 0.00 -0.00 rotate -90.00 -90.00 0.00
$attachment “anim_attachment_LH” “ValveBiped.Anim_Attachment_LH” -0.00 -0.00 0.00 rotate -90.00 -90.00 0.00
$attachment “anim_attachment_head” “ValveBiped.Bip01_Head1” 0.00 -0.00 0.00 rotate -90.00 -90.00 0.00
$includemodel “m_anm.mdl”
$includemodel “m_gst.mdl”
$includemodel “m_pst.mdl”
$includemodel “m_shd.mdl”
$includemodel “m_ss.mdl”
$surfaceprop “flesh”
$eyeposition -0.000 -0.000 70.000
$illumposition -0.637 -0.000 36.119
$sequence ragdoll “ragdoll” ACT_DIERAGDOLL 1 fps 30.00
$ikchain rhand ValveBiped.Bip01_R_Hand knee 0.707 0.707 0.000
$ikchain lhand ValveBiped.Bip01_L_Hand knee 0.707 0.707 0.000
$ikchain rfoot ValveBiped.Bip01_R_Foot knee 0.707 -0.707 0.000
$ikchain lfoot ValveBiped.Bip01_L_Foot knee 0.707 -0.707 0.000

Please, can anybody help me? Thank you very much! =)

[editline]25th January 2012[/editline]

Nobody? Please! I mean he is’nt a radgoll, he doesn’t collide with anithing. Thanks.

Ok, topic closed, I have found a solution. If someone got the same problem, do:
Find a .phy file from another ragdoll and adapt it to your playermodel. Thanks.

ORRRRR

$sequence ragdoll “ragdoll” ACT_DIERAGDOLL 1 fps 30.00

check the ragdoll.smd

Ok, thnaks, I will see!

Also it wouldn’t hurt if you exported your model for anims and save as ragdoll.smd too.

Ok, thanks! :slight_smile: