"NO STEAM APPS", have a legit copy.

Hey guys, I am having this problem with my garry’s mod.
Every time I try to start up the game, the loading screen comes up, closes and “NO STEAM APPS!” shows up.

I really have no idea why this is happening.
I just installed garry’s mod on a fresh computer, with fresh steam and new hardware, etc. I have no addons either.
I have had this problem one time before (about a year ago) and garry told me, that it was probably that I had used some steam cracker tool to get free pirated games in steam. I said that I hadn’t used them, but he didn’t believe. Anyway, now on a fresh computer that I just installed it on, I am getting this error again.

P.S I think this is supposed to be like an anti-piracy thing for the game, but now I can’t play :frowning:

Restart steam.

[editline]3rd February 2012[/editline]

Or restart your computer. Not that hard IMO.

Don’t forget to delete the .blob

if that fails, go to game properties, content tab, I think, and verify cache files.

Done all three.
No luck.

Have you ever used a steam crack or a crack for a steam game?

Maybe try reinstalling Steam?

read OP again

I remember getting this error once. I restarted my computer and started GMod again and it worked just fine. Also did you do both of these 2? Go to Steam, right click on GMod, properties, local files, “Verify integrity of game cache” AND “defragment cache files”?

yeah, it was fine for one game, but now it messed up again

Oh I remember this error. It appears when I opened “x” game and then stopped playing it, and tried to play GMod, I would get this error. OP, figure out which game is causing this/using steam.

Try creating a steam_appid.txt with just “4000” inside it (without quotes), then put that file inside your Steam/SteamApps/account/Garrysmod/ folder.

Bawbag, you forgot to rate that post dumb.

I don’t know why, but this happens almost every time you play a pirated game and then try to launch garrysmod (or any game?) through steam. All you have to do is ctrl+alt+delete and end steam.exe and launch it again. If that doesn’t fix it then I don’t know what will.


(User was permabanned for this post ("Admitting to warez. Pirated GMod(?) Post in RC, thanks." - Seiteki))

I think he means that after playing a pirated game and then playing legal Garry’s mod it thinks that GMod is pirated too.

Should still be banned for warez, probs not pirated GMod though.