"no steam apps!"

Hello,

Today I installed many addons. When I launched Gmod an error showed before the game loaded - engine error - “NO STEAM APPS!”. I also installed new water textures.
What should I do???!!!
Thanks in advance

Legitimate version of Garrys Mod?

Please provide a link to your steam account.

Here http://steamcommunity.com/id/noobmaster4eto

Re-install games or verify the integrity of their cache.

I tried both but it still shows me the error.

This belongs in Help & Support, not here.

Also.

Make sure you have a Source game (Half-Life 2, CS:S, TF2) installed and you have played it at least once.
If that does not work rename your garrysmod folder to garrysmodold and start up Garry’s Mod. (steam/steamapps/<steamname>/garrysmod)

i fixed this by restarting steam.

Verify the game files.

A: It’s pirated.
FIX: Buy the damn game.

B: The game files are corrupted.
FIX: Verify file integrity, or reinstall Gmod.

C: You have no Source games installed.
FIX: Buy/install a Source game (recommend CS:S)

D: You screwed something up.
FIX: Reinstall Gmod.

Your profile is private. As such, you probably pirated it.

Eh, why is it private?

Nope my account isn’t pirated I just don’t like people seeing my stuff but if you want to see it I opened it here is a link: http://steamcommunity.com/id/noobmaster4eto . And I fixed the problem by reinstalling steam.

Ooooh, so scary, people can see my games! What should i do?

Uh, well, whatever.

I wouldnt have my profile public if i had this on my page either: “๖ۣۜOne ๖ۣۜShoT ๖ۣۜOne ๖ۣۜKill ๖ۣۜNo ๖ۣۜLuck ๖ۣۜJust ๖ۣۜSkill”

He must be very pro . :allears:

OnTopic: Restarting steam has always fixed it for me, have you pirated ANY game, that MAYBE has an connection to steam, even though it doesnt show up in you’re games list.

I get this sometimes. Just restart steam!
Maybe delete that dirty clienregistry.blob

He said he’s already fixed it.