Not Able To Play

So every time I start GMOD up it loads into the menu normal and everything is fine, but when I try to get out of it with CNTRL-ALT-DELETE, ALT-TAB, ALT-F4, etc, it crashes my PC and when I get to ‘sending client info’ on a server it crashes my PC every time.

(I usually get around 100 FPS so my PC isn’t the problem I don’t believe)
My specs are:

CPU Stepping: 0x0
CPU Type: 0x0
Speed: 4019 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Supported
SSE42: Supported
AES: Supported
AVX: Supported
CMPXCHG16B: Supported
LAHF/SAHF: Supported
PrefetchW: Supported

Operating System Version:
Windows 10 (64 bit)
NTFS: Supported
Crypto Provider Codes: Supported 311 0x0 0x0 0x0

Video Card:
Driver: Radeon ™ RX 480 Graphics

DirectX Driver Name:  aticfx32.dll
Driver Version:  21.19.164.257
DirectX Driver Version:  21.19.164.257
Driver Date: 23 Nov 2016
OpenGL Version: 4.5
Desktop Color Depth: 32 bits per pixel
Monitor Refresh Rate: 59 Hz
DirectX Card: Radeon (TM) RX 480 Graphics
VendorID:  0x1002
DeviceID:  0x67df
Revision:  0xc7
Number of Monitors:  1
Number of Logical Video Cards:  1
No SLI or Crossfire Detected
Primary Display Resolution:  1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 20.91" x 11.77"  (23.98" diag)
                                        53.1cm x 29.9cm  (60.9cm diag)
Primary Bus Type Not Detected
Primary VRAM Not Detected
Supported MSAA Modes:  2x 4x 8x 

Sound card:
Audio device: Speakers (Logitech G933 Gaming
Memory:
RAM: 8150 Mb

My Drivers are updated too