Not compiling new version (please read for more info)

Ok so basically im working on a map, and i compile it, but counter strike loads the version of the map before of the new compile. There are no leaks or errors. I dont know why its doing this, yet its happened before. Help?

Post the compile log

We’ve all done this one time or another.

1: Delete the old files from your CSS map folder, just to be sure.
2: Check that, when compiling, hammer is running BSP, VIS and RAD. If it is not performing BSP, the compiler will simply re-compile VIS and RAD onto your existing map.
3: Post compile log if that fails.

Also double check to make sure you’re putting the BSP file into the right directory.

basicaly what khuskan said your vbsp is crashing check for bad brushes or func_detailed displacements etc
and post your compile log.

I’ve had this happen before, I was just forgetting to delete the old .bsp compilations.

that shouldn’t change anything. VBSP overwrites the old version if it completes successfully. Otherwise VVIS and VRAD will do their calculations on the old version of the map.

Well I know things like moving props would change, but lighting wouldn’t, and when I started deleting the old version of the .bsp, the lights were fixed on the next compile. I figured it all out at the same time I found out the difference between prop_static and prop_physics.

Unless you’re having compile issues with VBsp, removing the old files with have absolutely no effect, it’s automatically replaced, if you’re having trouble with the compile, use the Interlopers compile log checker, and then post it here if it doesn’t find a solution.

I’ve had this… I remember it was something to do with the validity of some of my brushes when it happened to me.

Oh fuck… Now hammer is crashing everytime i load that map. FUCK

I’m having the same problem.

I’ve deleted the old .bsp along with the old .vmf and it still compiles the old one.

I’ve gone through the compile log and fixed every error - even ones that wouldn’t have any effect on said problem.

Submit the compile log to http://www.interlopers.net/errors

It will explain all sorts of errors to you and tell you how to fix them.

Whats with the Bad Readings? I don’t see anyone else asking him to post the compile log to the Interlopers error checker. So there :colbert:

Is bsp on the run menu set to normal?

Guys i just said i cant post a compile log due to the fact that hammer automaticlly closes every time i try to load the map into it and i’ve already done interlopers it didn’t show any errors

Im probably going to have to delete it. I worked so hard and it was almost done! it was an almost exact recreation of Dead Center from left 4 dead 2 as a zombie escape map. :suicide:

your VMF is probably corrupted. Try opening the autosaves in C:\HammerAutosave. If those are corrupted as well, you can run your VMF through a VMF parser (IIRC VIDE can do this). This issue can arise if you used a quotation mark in any entity value.

By default, I’m pretty sure that the BSP is copied into two locations, one with the VMF and one in the /maps folder. You shouldn’t need to delete them though one it’s fixed, the tools will happily overwrite the old files.

If BSP is not running, it is either not set up properly in the Hammer preferences menu, you may be using an outdated vbsp.exe (i.e. episode 1 version with orange box maps), or, worst case, you’re VMF is causing vbsp to crash so badly and so quickly it isn’t producing any errors before it goes.

Unfortunately, for this reason I think my last reason is probably the answer to this problem… sounds like you’ve done something that is really, really illegal as far as BSP level design is concerned, inside out brushes or what not, to the point that vbsp and hammer both crap out before doing anything useful at all.

Double check this by making the simplest box room map you can and compiling it. If it compiles, then tif your last autosave doesn’t work, abandon all hope. If not, I’ll brainstorm it.

Save backups every hour or so to separate file names! It’s not rare for anyone to fuck up a VMF, and it’s a completely true fact that if you don’t have backups, then something certainly will go wrong.

VBSP doesn’t run until you compile the map. Corrupted VMF’s are more common than you think. Sometimes Hammer will mess up a save (the last 5 autosaves go to C:\HammerAutosave by default), and the autosave folder can help you with that. If you use a quotation mark in any part of any entity, it will think the entity value ends at the quotation mark in your value, instead of at the end of the value. This throws off everything because the last quotation mark in an entity will be considered a starting quotation, taking the brackets with it. This causes an unexpected EOF, and Hammer crashes.

He’s already said that the corruption tool did nothing. It’s not implausible that he could create a map-breaking brush in hammer, try to compile, fail, then be unable to open the map after he’s closed it. Also corruption fixers only fix certain things, there are bound to be some errors that slip the net.

Either way, it’s backups :o

I had this. What I did was open the .vmx (just rename it to a .vmf) in notepad, and deleted the brushes that had some line… I think the coordinates were #NIL or something similar to that. It then worked afterwards.

More than possible, try this as the easiest way of breaking your map:

  1. Open map/make new
  2. place a prop_dynamic
  3. Name it ““lol”” including the inverted commas
  4. Save and close the map
  5. Now try opening it again.

Another golden classic is getting hammer to crash while it’s writing to the vmf, you end up with an irreparable mess, usually just fragments of lines and brush data remain.