Notepad++ won't take GMod Lua Lexer

Alright, so I finally decided to get started with Lua with the help of this short guide:

But when I have to restart Notepad++ after installing the plugin, it comes up with this:

OK, I understand they are incompatible for some reason, but I am not the most computer-savvy guy in the world.

What do I do?

Should I downgrade Notepad++ to a slightly earlier version?

The plugin works great with Notepad++ v5.8.7 - Give it a try.

Reinstall it. It seems it’s missing.

Tried .7, .6 and .5, still no luck

Reinstall it?