NPC Weapon Issues

Recently, I’ve noticed a problem I’ve been having regarding NPCs and weapons.

Most Human NPCs, such as the default Citizens, are unable to do anything at all, and are stuck in a T-Pose no matter what weapon I have them use.

http://cloud-4.steampowered.com/ugc/595913395106584819/E2E45056C9E6121ECE62915F0ADEC57283E4F7BC/

http://cloud-3.steampowered.com/ugc/595913395106618580/994873E5930B736567D13634AFFF1580A387A8C8/

Some, such as Alyx, spawn normally, but go into T-Pose when firing at an enemy.

I see a few work fine and actually play the animations for shooting and moving, but, depending on the weapon, nothing comes out of their gun. The muzzleflash appears when the gun is fired, but no bullets appear to actually fire. This seems to happen more with the shotgun than it does with the SMG, for example.

http://cloud-3.steampowered.com/ugc/595913395106634263/CBF36E85DF195C936B10F3277FD76811C65527D7/

The same thing happens to some Combine NPCs, at least with the shotgun.

http://cloud-4.steampowered.com/ugc/595913395106710258/9C7BAB35135DAC77DB65E7F95C0426CC4F2792DA/

Some Combine NPCs also get stuck in T-Pose if they aren’t using the default models.

http://cloud-3.steampowered.com/ugc/595913395106730073/A8444453325086991DF4D9430C2F7C39FB582952/

Interestingly, I’ve also noticed that some of the sounds usually don’t play when an NPC is firing their gun. Player versions of those weapons seem to work fine. What files should I look at to correct this? All of these models worked fine about a week ago, I’m wondering if anything new I added since then changed some animations or something. What files should I be looking at for the issue?

The sound issue will be fixed in the new update. As for the lack of animations, it’s a known issue. When models are in T-Pose, it means that the entity doesn’t have the animation for that specific action; in this case, the NPC doesn’t have the holdtype animation for that weapon.

It’s strange how it’s happening with the default citizen models, however. They used to work fine, and I’ve done nothing to them aside from replace the texture. Even then, they worked fine until a week ago. I was thinking maybe I could add/replace the weapon animation for them myself, where should I look in my GMod folder for that. Also, where do I access HL2’s assets? I have HL2 installed, but I haven’t been able to find the original asset folder/VPK like I have for L4D.

  1. You can’t just “replace an animation” without decompiling the model. You could see if an addon is overriding the model and causing it to T-Pose, but again, it’s most likely from the lack of a holdtype.
  2. HL2 content is included with GMod by default. Check under games/Garry’s Mod in your spawnlist.