NPC won't move through house despite nav_mesh

I’ve googled and read up on what I could including Valve’s nav_mesh forum. I am using a huge map (gm_hillscape) and use Source SDK to create a nav_mesh (I followed the steps at the bottom of this post http://forum.facepunch.com/showthread.php?t=1380012). However the NPC (using NPC tools) won’t go in the house when I click in there. I’ve tried manually making some areas, connecting them back and forth and making them walkable. There must be some basic step I am missing. Here is a screenshot to give you a reference. I am trying to make it so the NPC can move into that house but he has trouble even going across the lawn. I have to basically make him move a few feet at a time. I thought this was because there was no nav_mesh so I generated one. Any ideas?

Imgur

NPC do not use nav mesh, they use AI nodes.

This is what it should look like:

http://images.akamai.steamusercontent.com/ugc/37481700634447599/3EDB86A20475BF2484071E3FD042DD1B07FA62B5/

Where the heck did I get navigate meshes from… I guess I confused bots with Npc… Please tell me I can make Ai modes in garry’s mod on the map itself and not have to go to hammer…

.

You can I think, “map_edit [mapname]”.

I stand corrected.

can I use this in garry’s mod or does it need to be just half-life 2?

it should be ok with Gmod when hammer is open too, i’ve never tried it out so can’t really say personnally