Nvidia kerdel drivers crash after 10-15 minutes of playing ! {NEED HELP}

So basically my problem is that after joining to the rust server my kerdel display drivers are crashing and I don’t know why ;_; I tried to set everything graphic setting to low but it didn’t help:/ SO i’ve got one question, have anyone the same problem or do someone have a way to repair this ? And btw only in the rust those drivers are crashing :confused:
My computer specs:
I5 4670k
GTX 770
ram 2x4gb 1600mhz

What version are your Nvidia drivers? (xxx.xx)

355.60

Card is probably either over heating or is taking too long to respond and so windows auto-restarts it. check your temps with nVidia inspector and try this.

Okay, that’s the latest version. Monitor your GPU’s temperature while playing.

Also, type this in the F1 console: fps.limit 60

Or, if you can’t hit 60 consistently, 30.

I had this, drove me mental.

I resolved it by using the latest non game ready nvidia drivers sorry I cant recall the version etc. But it worked.

yea i use the latest official drivers and since i’ve updated to latest rust ( a week ago) i got 2 drivers crash while playing about 15-20hours maybe (every other games is running fine with no drivers crash, i mean it’s a rust game problem only).
win10 x64

the fps.limit 60 tip is also solid.

You could try underclocking the gpu 200mhz and test if the error still ocures.

You… Just… Said… Underclock…
It’s been a loooong time since I’ve heard that, if you end up in the situation where you have to underclock, there is something either very wrong with your cooling, or your GPU is possibly on the way out, don’t blame Rust, a program wouldn’t force your GPU to work over its cooling capacity.

Check all your vents, fans, heatsinks and even thermal paste if you can and clean if needed, if it’s overheating, then this should help, if not, you GPU has possibly reached the end of its life and you’ll have to underclock untill you get a new GPU. If your performance is good in other games, they probably aren’t making you GPU work hard enough to make the overheating noticeable.

As for me I am playing Arkham Knight, Bioshock Infinite and stuff like that without problems, no overheating there.

In rust I get slightly more temperature but no overheating. I did underclock my gpu 200mhz and play in directx9 and the display driver crashing stopped. Gotta test if the underclocking or the directx9 fixed it.

its the driver trust me.

go in nvidia control panel>manage 3d settings>global settings; and the look for “Power management mode” and change it to Prefer Maximum Performance
it helped me at some point and i guess its the same thing with you op,gl

I tried everything but it’s still crashing. I guess I will need to live with this._. but anyway thanks for help :smiley: