Object Properties: multiple objects showing up when selecting quickly

Any way to stop this from showing up when I control click on different things quickly? It gets annoying having to slow down your clicking after a while.

what does you hammer layout look like ? the visgroups should be nested on the bottom right hand corner and would only pop out if you clicked on it by accident, you could click view then screen elements to untick the bars you don’t want to see

…? Has nothing to do with layout, that’s just what happens when you double-click. You can try messing with Windows mouse settings to change what it recognizes as a double-click. Or you can just move that window off to the side until you’re done.