odd as balls Source texture/rendering error

so i’ve got this giant whooping mech that i’ve made and ported to GMod, and it’s got a problem with the texture on its lower leg armor. and it looks just right in HLMV

basically this

http://files.1337upload.net/texture_error1-281cd9.jpg

and, ugh, Garry’s Mod:

http://files.1337upload.net/texture_error2-5e2862.jpg

the UV isn’t even mirrored at that spot on the original texture, it’s not mirrored at all

i had this problem in HLMV too, in a different location but still on the leg armor. fixed it by compiling the leg plates in separate SMDs, but that seems to have nothing to prevent the error in GMod

and it only affects the diffuse, which is extra weird. as stated in the second pic, the normal maps and shaders related to them follow the correct UV

what the fuck do i do

  1. Post the VMT;

  2. What version of studiomdl are you using?

here’s the VMT


"VertexLitGeneric"
{
	"$baseTexture"	"models\joazzz\warhammer40k/titans/legio_gryphonicus/warlord_armor"
	"$bumpmap"	"models\joazzz\warhammer40k/titans/warlord_armor_n"

	"$phong" "1"
	"$phongexponenttexture" "models\sm\ultra_high/armor_exp"
//	"$phongexponent" 30
	"$phongboost" "4"
	"$phongfresnelranges"	"[.5 1 7]"
	"$PhongAlbedoTint" "1"





}

i compile with Crowbar; so far i’ve been using the HL2 studiomdl, which should be the Orange Box/Source 2008/“engine version 1.whatever” version after Valve ported the old games to the more updated engine

think it might work better with the SDK Base 2013 MP studiomdl? motherfucker takes a full 10 gigs of disk space for no reason though

The 2013 MP base is close to 4 GB. You’re thinking of the SP base, which is somewhere between 8 and 9 GB total.

AFAIK, it’s better to compile with the 2013 MP or Gmod’s studioMDL’s, since they account for some things the SP version does not.

Also, what format did you import the texture into VTF Edit, and what settings?

i’ll try that then

TGA into DXT5, like always

issue solved, thread can be closed. thanks for the help

what’d you have to do though, in case anybody else gets a similar issue

just used the 2013 MP studiomdl

the problem came back, in a different spot. i’m still using the SDK 2013 MP studiomdl. what fucking studiomdl am i supposed to use to get rid of this?! the goddamn model isn’t even 50k polygons, it’s not supposed to glitch out like this, i’ve managed to compile models with almost 100k triangles without any problems so what the hell???