Odd glitch after trying to install A flatgrass map.

So I loaded up Garry’s mod A few days ago and when I bring up any weapon or tool or anything it stretches the texture out into the middle of the level. It also does this for rag dolls and special effects. Is there anyone out there with the same problem? Or anyone with any ideas on a fix? Thanks.

       Here's A link to some screen shots showing what I mean: http://s1108.photobucket.com/albums/h410/Murphy_232/

I’m not helping you until you can prove that you own a legal copy of gmod.

Okay? Well It’s a legal copy. And how am I suppose to prove that?

You give us a working link to your steam profile.

Probably this guy

Why would anyone want a flatgrass map.
Its all the same shit.

Why the hell would you be installing a flatgrass map anyway?

I don’t know it was a re-textured flatgrass and my computer sucks. Point is, my game is all muffed up and I’ve tried re-installing it and I still get the same thing. Should I try re-installing steam and all that?