Odd problems after update

Hi, my DarkRP gamemode worked perfectly fine before the update. However after I began receiving this message:
[ERROR] gamemodes/darkrp/gamemode/client/vgui.lua:270: attempt to call method ‘JobsTab’ (a nil value)

  1. unknown - gamemodes/darkrp/gamemode/client/vgui.lua:270
  2. unknown - gamemodes/darkrp/gamemode/cl_init.lua:232
    I checked out vgui.lua and notice nothing different. I did some tests and deleted the line so it would move onto the next ‘Tab’. It returned the same error (except the method name of course)

Any ideas of what the underlying problem could be?

Edit: Half my addons are not working either, however they’re being added to the FileSystem on startup…

Edit: Found the problem fort the addons, turns out capital letters in the addon folder names will fuck up your day.

[ERROR] gamemodes/darkrp/gamemode/client/showteamtabs.lua:413: attempt to index global ‘GM’ (a nil value)

  1. MoneyTab - gamemodes/darkrp/gamemode/client/showteamtabs.lua:413
  2. unknown - gamemodes/darkrp/gamemode/client/vgui.lua:269
    3. unknown - gamemodes/darkrp/gamemode/cl_init.lua:232
    Getting odd errors with GM: now…