Older protocol server

My gmod server after the update has been saying that its using a older protocol than my client am I ment to update my server or do something else I have no clue how to fix this problem?

Typically after every gmod update you need to update the server, same goes for pretty much any source game

Im really new to servers but how do I update it?

Is your server Linux or Windows as I been having problems with Linux. Windows servers seem to be fine but Linux servers broken. XD

Windows 7 I dont know how to update it