Oops! The game crashed - Can't seem to get passed this launch error

Hello,

I’ve been having this problem that when launching the game it will immediately produce the good ol’ “Oops! The game crashed” error.
I have not ever seen the actual application come up, just the error.

I’ve done a bit of digging and it seems that people mainly experience this when having 4 GBs of RAM or are on a 32-bit OS.
I am on Windows 7 64bit and have 12 gigs of RAM. I also tried with 8, and 4 and can replicate the error.

I’ve tried launching it directly from the file source rather than Steam.
Ran Steam and the game itself as Admin, no luck with anything I’ve found as possible solutions.

Also, I’ve tried the disable your headset/speakers thing that some people have found useful, no luck.

Here are the logs:
Error: http://pastebin.com/TewPchEZ
Ouput: http://pastebin.com/BxfimNYY

Hoping that someone can pick through the logs and help me out here.

What’s your video card? Because this is almost guaranteed the issue:

Well fuck me, my GPU wasn’t being used it was trying to go to the integrated.
It was indeed my GPU and I’m playing now, thanks elixwhitetail.