Open Console - Crash

Log:


Initializing Awesomium..
No Kinect SDK
Lua JIT is DISABLED!
Unknown command "cl_thirdperson"
JOY_AXIS_X:  mapped to Turn (absolute)
JOY_AXIS_Y:  mapped to Look (absolute)
JOY_AXIS_Z:  unmapped
JOY_AXIS_R:  mapped to Forward (absolute)
JOY_AXIS_U:  mapped to Side (absolute)
JOY_AXIS_V:  unmapped
Advanced Joystick settings initialized
Unknown command "hud_showemptyweaponslots"
Unknown command "sv_backspeed"


What can i do?

unsub and remove your addons

verify all games

re-install gmod with a clean install (as in delete the directory and then delete the local content and then re-install)

Make sure your game does not run in DirectX 8.

Did all i have DirectX 11 nothing worked before the update everything worked…

Having DirectX 11 installed doesn’t mean the game runs with DirectX 11.

How to see with what it runs ?

In the Advanced Video Options you can see Hardware and Software DirectX levels. The Hardware one is the one that GMod is currently running in.

Its DirectX v9.0 it says, but what can i do to fix this problem i cant play gmod so anymore ?

[editline]11th March 2015[/editline]

I hope the developers fix that or i cant play it anymore.

anyone who can help?

How did you get the console log if you can’t open your console though?

I can only open it if i opened gmod and i’m on the homescreen not in game.

[editline]11th March 2015[/editline]

Who can help? Or i cant play gmod anymore.

No developer can help?

Just put put this in the start up parameters -dxlevel 110 and you should be good.

Didn’t work i reported this now to the gmod issue tracker.

No one could help me they destroyed the game for me.