Opening console in Garry's Mod?

So i’m in game Gmod 10 in sandbox and i press ~ for the console but nothing happens what am i spose too do?

Like any other source engine game. Go into keyboard options -> advanced -> enable developer console.

Or steam -> My games -> Garry’s Mod -> (mouse2 click) Propeties -> launch propeties (it says only for advanced users) -> then type -console there.

Steam way: opens console at startup, obscuring that nice background.

If you still can’t open the console with ~ then you are probably using a non-English keyboard layout. Numerous sites explain how to open the console on German layout. If you have Hungarian layout, then forget about opening the console in any way other than -console because ~ isn’t on the keyboard (well, it is but it’s AltGr-1 and it just don’t work; I learned it the hard way). You can’t redefine either because Source resets the console key bind on every startup.

go to

find the text doc con fig and add

you can replace “`” with any key on your keyboard like “l”

save and load up Garry’s mod

What if you bind it to 2 keys? 1 (~) and 1 (’) for example. Then I guess source would say it’s alright and won’t bother about the secondary bind

No, I mean if I modify the original line of the bind, Source rewrites it. And if I bind it to another key (so it has multiple binds), that key doesn’t work either. Summary: the only way to open the console is -console or -dev. If I accidentally close it, I have to restart <Source game here> or I’ll have to live without console.
I suppose the problem is with the default keyboard language. Windows defaults all programs to Hungarian and even if I change that, clicking on <Source game here>‘s window resets the layout to HU, not EN (changing one program’s layout doesn’t affect the others’). And I can’t change the default language to EN because I don’t have the slightest idea how to do that; I can’t delete HU layout either because it’s the default. [/rant]

Say in chat:

";con_enable 1; bind F12 toggleconsole;

Make sure you include the ";

You can use say to use console commands? Never knew that before. I usually just set the -console launch option and then “bind f10 toggleconsole”. That just usually makes me press f10 in any sourcegame when I try to open console. If I have forgotten to bind it, it will make me quit the game.

To clarify: if I do that and press F12 (or whatever key I used), nothing happens. If the console is open and it’s language is EN, the key will close it but it won’t open again.

For some reason toggleconsole doesn’t work for me, so I use “showconsole”

Try this, it has worked for me, so I think it will work for anyone else:

  1. Go to C:\Program Files\Steam\Steamapps\Your Username\Garrysmod\Garrysmod\cfg

  2. Open the file called config.cfg in notepad

  3. find the console line and change the bind to any key you want then proceed to save the file.

  4. Right click on the same file, go to properties, and tick the box that says “Read Only”

  5. Open up Garry’s Mod, wait until it finishes loading then close it.

  6. Go back to the config.cfg file, right click -> Properties, then untick the Read Only box.

Now you can start the game and you are good to go.

Thanks for the help. I was looking for a fix like this.

Why the hell are you guys posting these useless commands when the first post explained it.

Update: I since discovered that the reason why I couldn’t bring up the console was that the console key doesn’t work in the menu. If I press it in-game, it pauses the game and brings up the console. Yay!

Something went horribley wrong for me, i cannot open console, at all, no matter what. Also, i cannot use backspace in text. i think i picked up some little lua virus, but i havent downloaded anything in ages,
this goes for both singleplayer and multiplayer.

Chances are your keyboard’s broken.

At least your “bump thread” key is working fine. :v:

@ General Lee: Alt tab out and back in.