Opening Rust Experimental Causes Severe Computer Error

When launching Rust Experimental, this error appears:

I got it to work with Bitdefender! Here’s what I did!

  1. Right Click Rust in Steam and hit “Delete Local Content” (This will uninstall the game.

  2. Then, open up C:\Program Files (x86)\Steam\steamapps\common\ and you will see Rust, right click it and hit “Delete”, wipe your Recycle Bin.

  3. Restart your computer and open CCleaner (https://www.piriform.com/ccleaner) and run the cleaner and registry.

  4. Restart again.

  5. Now, open Steam and reinstall Rust BUT BEFORE LAUNCHING IT go into your Bit Defender firewall exceptions settings and add both the legacy Rust.exe and Experimental Rust.exe’ as well as Easy Anti-Cheat Setup.exe, etc.

  6. Run Easy Anti-Cheat Setup after it’s been added to your firewall exceptions.

  7. Boot experimental and thank the gods. (:

Hope this helps!

Damn, sorry about that. Recently we have received few similar notifications, any chance you’re using Bitdefender?

I am getting this error too. I can just click OK on it though. And i am running Bitdefender Internet Security.

Correction: It seems to make steam un-responsive. I can click “Play” on any game on steam, without anything happened. I can close down steam via the task manager but i am forced to restart before i can run steam again.
It may be worth mentioning that EasyAntiCheat pops up with an error before the errors shown in OP’s post comes up. Tried to click “Send Report” but it failed.

I am, which is odd because prior to the error, I was able to launch Experimental Rust just fine, etc.

Thanks for the quick response!

i have the same problem, how do i get round this i also use bitdefender.

We have contacted BitDefender regarding this issue. In the meanwhile, I’m afraid the only solution is to disable BD before starting the game.

I will try to also download BitDefender and reproduce this locally, are you using the latest BitDefender version?

Yaph. Internet Security 2014 here.

yeah me to.

How can we report this to Bitdefender?

Sorry about this issue. I have sent few emails to BitDefender about it with information how to reproduce it, we’re currently waiting for response.

You could report it also via their forums, http://forum.bitdefender.com/index.php?showforum=138, maybe this will motivate them more.

What do you want me to report? the EAC .exe or ?

Hi,

Please try this suggested resolution from BitDefender. If it doesn’t fix the issue for you, could you possibly send the logs to bdsupport@bitdefender.com, thanks.

knobbie, looks like they gave you a canned CS response. Try contacting them as a business to business inquiry to get you whitelisted. That response is going to make some users weary if they have to turn off Intrusion Detection.

Not sure, but if that’s the case it seems that they are expecting the intrusion detection system specifically being the culprit most of the time. :confused:

If possible, please anyhow send a log to them if it’s not too much trouble. Hopefully disabling that system will already fix the issue.

Thanks for the tip @ B2B, I’ll try that channel.

I’ve tried disabling the entire system through BitDefender and also adding Rust.Exe, EAC.exe, etc to firewall permissions and the like and to no avail, still getting the issue I reported above.

Almost about to remove Bitdefender entirely, but they gave me a year of their version for free, so I’m trying to enjoy it while I can! hahaha.

Hopefully there’s a solution soon before the big update!

Could it also be that the new addition with EAC could be detected by BitDefender and BitDefender is locking the computer down to prevent what it thinks is a phishing?

That’s pretty much the operating definition of a false positive, and those happen all the time. Rust has been incorrectly flagged as malware (likely due to Cheatpunch’s stats logging) multiple times by different security suites.

And until BitDefender trusts EAC and stops freaking out about it, the workaround is to make BitDefender get out of the way (and be less protective).

and how does one do this without removing bitdefender?

The fix suggested by eac knubbe doesn’t work for me I’m afraid. Thanks for trying. has anyone had any success fixing this error? If EAC is the issue wouldn’t it be helpful to use an alternative anti-cheat? I’m using Bitdefender Total Security.

Wouldn’t it be better to fix EAC?

EAC - things have gone quiet?