$origin not working

so, i’ve animated all the sequences i need for a swep,and compiled them, but it appears that they aren’t positioned correctly, so i tried using $origin X X X X so i wouldn’t have to go through and re-do all my sequences but it doesn’t seem to be effecting it at all
here is my QC code


$modelname	"submod\weapons\blowtorch\wep_blowtorch_v.mdl"
$cdmaterials	"models\submod\"
$cdmaterials	"models\Weapons\V_hand\"
$body studio	"v_blowtorch_base"

$origin 0 0 -90 90
// i've tried alterations to this but nothing seems to effect it, like 0 0 90, 0 0 0 90, 0 0 0 -90 etc 

$sequence idle "v_blowtorch_idle" loop fps 30 activity ACT_VM_IDLE 1
$sequence draw "v_blowtorch_draw" fps 30 snap activity ACT_VM_DRAW 1
$sequence holster "v_blowtorch_holster" fps 30 activity ACT_VM_HOLSTER 1
$sequence attack1 "v_blowtorch_attack" fps 30 activity ACT_VM_PRIMARYATTACK 1
$sequence attack2 "v_blowtorch_attack2" fps 30 activity ACT_VM_SECONDARYATTACK 1

other than the models being 90 degrees yaw off the aim, and a little to high, the model displays correctly, animates correctly, its just off center and it doesn’t look good at all
does anyone know why it isn’t working?

Thats your problem theres only 3 axis to move it on your using 4 @.@


$origin 0 0 0

Thats the format.

Also $origin is not rotation, it is diplacement. You need this command at the end of each sequence line to rotate:


rotate (angle)

The QC command $origin adjusts the position of a model within its own local space. When the model is created, it will be offset by the X, Y, -Z and Z-rotation values provided.
taken from http://developer.valvesoftware.com/wiki/$origin

It’s wrong ^^ I’ve used it quite alot, I know what i’m doing.

Though it would be useful if the 4th value actually worked.

silver, it does work, it somehow just now worked, i deleted my old files and recompiled into a fresh file, and now the Z rotation works correctly, however i cant seem to use the other 3 values, no matter what i enter for the Z offset, it doesn’t change, and the Y offset seems to push the model off to the side rather than up/down or forward/backwards
edit: is it possible that the 4th value also effects the Y offset? if thats the case i think i might just use rotate (angle) in the sequences as you suggested

Ok, that is interesting, as i’ve not got it to work before.

And yes its likely the rotation will rotate the axis aswell that you are using. We tend to use the sequence rotate anyway.

I figured out what was happening.
im used to working with LUA, to update your changes, all you have to do is reload the map, but for models you have to restart the game
is there any way to reload the models without restarting the game? like a console command?

Use the modelviewer found in the SDK. Of course you need to add the Garry’s Mod directories first into the GameConfig.txt located somewehere in the sdk folder.

Try “find reload” in console and see if anything looks promising