Other players can't pick up weapons

It seems other players cannot pick up weapons in my server. unlike other peoples problems, (which i searched up) the gun doesnt just float around or stay on the ground. The people in my server pick up guns but they just simply disappear. they dont enter the other people’s inventory. my friend presses E on the weapon on the ground and it simply disappears. When i try and press E it works just fine. Im pretty sure i installed Css content on the server. also ran steam update. any sugestions?

Do you have some sort of weapon protection plug-in stopping non-admins from picking up weapons?

All i have installed is New admin and Assmod. but im pretty sure thers no like weapon protection defaulty enabled. if you want to join my server you can try it. i dont need to be there. just spawn a weapon and try to pick it up and see what happens.

rp_license 0 would usually work,(if its RP) but you say the weapons disapear when they press e?

And hint, I believe ULX is a lot better than assmod…

yes, the weapons completely disappear. and the person doesnt even have to press E, they can just walk over it and it dissappears. when they try to spawn a gun thru the Q menu, nothing happens. and i enabled Q spawnable weapons to admins and the admins couldnt even spawn guns to themselves. and when they tried to spawn weapons on the ground theyd walk over them and the guns would disappear and vanish. any suggestions? is ulx really that good btw?

Omen, i tried using NewAdmin for my DarkRP server and had the same problem. Want your answer? Here:

Delete NewAdmin,
Get ULX, and ULib.

Have fun.

Thank you man, ill try that and get back to you

k :], haven’t tried it with ULX/ULib + ASS, so…still let me know though

Good Luck

-Abacabb

with assmod, it doesnt seem to be working :confused: whats your steam name?

Abacabb

alright. ive added you. We can try to fix this problem together. Right now, i have just ass mod installed. it seems to be nicer than the other admin programs because it activates an admin tab for the rp system itself. it allows u to change settings for the rp that u normally couldnt do. thats why i like assmod. however, with ass mod the problem of guns not being able to be picked up exists. or should i say used? since the player can pick up the gun but it simply vanishes when they do pick it up. update you more once i experiment without assmod installed.

Alright man. On my server I ONLY run ULX/ULib, with those it actually activates an admin tab on the F4 rp menu. I love NewAdmin, and ASSmod, but if it fucks with my game, its out.

-Abacabb

okay so ulx and ulib will run well with darkrp?

whats the easiest way to make yourself admin with it?

Type ‘ulx menu’ in the console (without the 's) and it should guide you from there…just read everything and theres a command for player managing. Enter that, and just follow what it says, if you can’t figure it out let me know :]

-Abacabb

ok i got it. nice it works. thers only one problem im having. and thats when i switch to gundealer, i hit F4 and thres like a sub menu thts like stuck in the corner of the screen. ill post it in a sec.

EDIT: alright here we go, the screenshot.

do u see the stupid box up on the left corner? it stays that way if u hit F4 wen ur a gun dealer, for the rest of the entire game. unless u quit out and come back.

Alright there. i posted the screen shot.

so the following problems i still have.

weapons auto pick up wen walked over. none of the “press E” business. which sucks! idk how to fix

and the second, the gun dealer glitch thing. anyone got ideas?

Update to the latest SVN of DarkRP. SVN Tutorial: http://www.facepunch.com/showthread.php?t=688324

If you liked NewAdmin and want it back, do this to remove the thing that makes non-admins unable to pick up weapons:
1: Go to newadmin/lua/na_plugins/usergroups.lua
2: Scroll down to the bottom of the file
3: Delete this code:


//=== Special limits ===

function BlockGuns( ply, wep )
	local all = HasPrivilege( ply, wep:GetClass() )
	if !all then wep:Remove() end
	
	return all
end
hook.Add( "PlayerCanPickupWeapon", "NoGuns", BlockGuns )

//Entities allowed?
function NoSENTs( ply, ent )
	return HasPrivilege( ply, ent )
end
hook.Add( "PlayerSpawnSENT", "NoSENTs", NoSENTs )

I’m having the same problem, but i only have assmod, should i delete it?