OVH Dedicated Server, Clients unable to see nor join servers.

Hi facepunch, I recently changed hosts to OVH but I’m having a really serious issue with the server. Approximately 80% of my playerbase are unable to see/connect to the server. They can ping the dedicated server fine and get a response back but whenever they try to connect to one of the servers it just times out as if the server is not up. I know the server is up because I myself am on it but when they open my game info in steam it shows the server as not responding, If they then try to join via console “connect <ip>” the connection just fails after 6 retrys. Sometimes the people can see the server for a short time but then it disappears again. I myself can see the servers fine and haven’t once not had them show up same with most of my other higher ups.

All my clients can join the Teamspeak 3 server absolutely fine, I read on a thread that “OVH reject any first connect” and thought perhaps this means that if people are on teamspeak it somehow classes as a first connect then they can second connect to the gmod server? But haven’t been able to test this theory. This doesn’t seem to make sense because joining teamspeak is a single connect also so they shouldn’t be able to join that. But if there is a way to turn off rejecting first connect I am open to trying it.

Gametracker was not able to ping the servers either but we managed to fix that by clearing the iptables firewall so we assumed that this would fix our clients issues but it has not.

We are using TCAdmin on an OVH ‘MC-64-SYD’ Dedicated server with Ubuntu 17.04

Dedicated Server IP: 139.99.144.110

Any help would be greatly appreciated, We have contacted OVH support but are waiting for a response from them so I figured I would ask the facepunch community in the meantime.

All our servers, Priority is DarkRP (27016): https://www.gametracker.com/search/?query=139.99.144.110

You should probably wait for the response from OVH, I had networking issues with a VPS once and after reaching to a engineer they fixed it on their side

:wink:

Sounds like hosting issue tbh…

Have you tried running up a fresh gmod server and seeing if people can connect?

oh hallo there Gav, Yea we have tried that a few times to no avail.

@Datamats Yea we are waiting on OVH but I guess it’s the weekend over in the US right now as they haven’t responded to our ticket yet and it’s been more than 48 hours.

EDIT: Also starting about 24 hours ago for some reason all OVH’s Australian servers have started routing through Miami and so every single Australian OVH dedicated server is getting 400+ ping ¯_(ツ)_/¯

Ok so as it turns out OVH has multiple firewalls, What we had to do was unblock the GMod/hl2 port (27015)


OVH Control Panel > IP > Click the settings wheel > Configure the GAME Firewall > Deactivate the restriction

I’m still not sure as to why a minority of people could see it but it’s fixed so I’m happy.
They also fixed the problem with Australian dedicated servers routing through the US which was an issue with an ISP.

Just figured I would update in case someone else has the same problem with their gmod server on an OVH dedi so they can find the solution.